Spitz AX (GL-X3000) issue with Good Cloud

Is Spitz AX supported in GC yet? It’s on version 4.3 (display shows 4.0 release10300).

Tue Apr 25 15:19:39 2023 daemon.debug eco: (/usr/bin/gl-cloud:254) fetch server from: https://gslb-us.goodcloud.xyz/gslb/getbucket?deviceType=1&mac=XXXXXX&sn=XXXXXXX&ddns=XXXX&timestamp=XXXXX&sign=XXXXXX
Tue Apr 25 15:19:39 2023 daemon.debug eco: (/usr/bin/gl-cloud:278) server resp: {“code”:-5,“info”:“”,“msg”:“tls device info invalid”}
Tue Apr 25 15:19:39 2023 daemon.err eco: (/usr/bin/gl-cloud:284) fetch server fail:-5 tls device info invalid
Tue Apr 25 15:19:39 2023 daemon.err eco: (/usr/bin/gl-cloud:517) reconnect mqtt in 5s…

Spitz AX is supported in GoodCloud.

Please ignore this. The version number of Cellular router cannot be changed because of the authentication requirement. So we will show v4.0 as the main version number in Cellular router.

Does your device always show offline?

Sorry, there is a bug in GoodCloud that prevents the device to connect to the cloud.
We have fixed it, please try again.

I was able to get mine connected to the cloud yesterday after updating to the beta firmware from Apr 15

Beta 4.3.4 6-21 Good cloud access not working. I have tried disabling/re-enabling, and reboot router. Good cloud just shows x3000 as offline.

This is a bug in the firmware. the fix has been compiled and the link to the download center will be updated later.

Which firmware has the fix for good cloud, because I’m on the latest official firmware and can’t connect to it with a Spitz.

May you share the logs with us?

I can connect with deleting device and adding again, but a reboot loses connection, and I have to go through the whole process again. Where, which logs?

Should be located inside the GUI → Logs
There should be cloud log or at least kernel log.

I think I’ve found the issue why good cloud comes and goes. in DDNS test I get * IP from DDNS Domain Resolution

  • IPv4 xxx.xx.xxx.xxx
    But in Interface WAN IP, I get no address.
    And the router ip address is xx.xx.xx.xx which I have read means behind NAT, no public ip address.
    I found the issue failing to get a WG server running, although Good Cloud is up and working now, which is strange if I’m behind a NAT??
    I guess I need to change network operator!

GoodCloud does not depend on public IP nor DDNS, so this should not be the issue.

1 Like