Spitz AX GL-X3000 - Won't connect to Cellular Network

Hello, I have a Spitz router that was working with cellular data perfectly, when I deployed the router in Atlanta (router travels with me around country) it would not connect. The sim plan is full, full signal strength, tried auto setup, manual setup with different APN’s (I didnt have to do any of this before). I’ve factory rest the router, reset modem - Nothing has worked.

I tried flashing the modem firmware itself and kept running into an MD5 check error, so I have no idea what to do next.

Does the card work on your phone?

Flash the modem using the Uboot method and latest firmware.

Excuse my ignorance, but how do I flash the cellular modem using the uboot method?

I was following this guide:

I will test that tomorrow, but it should as nothing has changed with phone plan. The only difference is that I am in a new state. I have traveled with this router and it has not given me this issue before.

Can you let me know which carrier are you using?

Is the SIM static IP or dynamic?

1 Like

I’m using a Data only pre-paid sim from eiotclub. I’m not sure, because it doesnt connect at all.

What APN did you use?

Also have you tried the SIM directly on your phone?

mobile.three.com.hk and mobile.lte.three.com.hk

So this is a roaming SIM from Hong Kong. Pls verify in your phone if it is working OK.