Spitz AX NR not saving settings

Just received my Spitz AX last week. Took some doing but i got it to work with Visible (VZW reseller) and Boost Infinite (currently ATT only) SIMS. But the frustrating part is when i power cycle it. I have moved it from inside the house to a couple different vehicles to provide access when on the go and the settings do not pick up where they left off. Its requiring me to use a device to login into the router and change the required settings each time its booted. Like its defaulting back to the first options for the ANP, etc when it power cycles. Not a huge deal but kind of annoying. I have updated to the most current beta firmware as there arent any stables available yet. Im sure this will be addressed as it comes out of beta, i was just curious if this is the same experience other users are having with this new beast. Im loving this thing, its quite the upgrade from the 750v2 i have.

We are sorry for this inconvenience to you. Could you give us more information about your usage? You insert VZW and ATT both SIMs at the same time, and hope each SIM can select the suitable APN automatically, or you change the SIM from VZW to ATT, but the APN setting is not switched correctly? We will analyze this issue.

Hi. Thanks for resonding. I have the vzw sim in slit 1 and att in slot 2. I plug in the router and it boots and wont connect. I login and go to the apn settings and change it to an apn that will connect. But then say i want to move it to a different location. When i unplug and move it i have to do the same thing again. It doesnt save the configuration i selected. Ill have to sign in again and change the apn settings again as it reverts to the first option in the apn settings.

One solution is after you input the APN for each SIM, please save the setting as below picture, the Router will remember it and select the right one. I tried this solution before and it works fine.

I will give feedback to our developing engineer to improve it, Router can remember the setting automatically would be more convenience for end user.

Same behavior on my end.

I tried with latest version Version: 4.3.1 firmware, even I choose the “Save Settings” button to on with description, After “Apply”, I cannot see it being saved in the manual setup list.

Still will lose settings for TTL after powering off and on.

can you share your settings for those two sims. I am going to have those two as well. Thanks.

1 Like

These are the apn settings that ive used and they work for me. As far as saving, i havent tried on the newest firmware but saving them did work for me on the last firmware. But the issue is that you cannot assign specific settings to be used with specific sims. When switching between the sims, the settings will default. Then there will be no connection. Requiring you to login and choose the saved setting or just do it manually. So with the current sims i use, the auto failover feature would be usless as it would default to the wrong settings for the next sim.

I am absolutely loving this thing tho. With a few things fixed in firmware revisions, it will be perfect for my use cases.

For your TTL woes, go into luci and set a firewall rule for postrouting. That saves and stays there.


Same behavior for me. TTL setting does not survive a reboot. I ended up just adding the TTL rules manually via Luci.

I did the luci route from the beginning. What way are you doing it where it doesnt save?

In the cellular settings dialog box I’m entering the desired value in the TTL field and clicking on save. After a reboot the field is blank.

Oh ok. Well in luci it was super easy to do. For now i guess thats the only solid way. Im sure they are working on that issue.

thanks to both of you! I haven’t used luci, do you guys have any quick doc for that rules?

Hi doczenith1:

You can view the TTL on the following page.

@lizh , that is the field that I enter the 65 value in and click apply. After a reboot when I come back to that dialog box the field is now empty. I’ve also enabled the Save Setting option but that did not work either. I’m using firmware version 4.3.1.

I have test and it is ok.But maybe the current mechanism is not so friendly that it might work incorrectly. We will optimize SIM card configuration as soon as possible.

1 Like