Spitz AX3000 - Add Lock Current Tower Button

Good morning all,

When I am connected to a good 5G tower I find it difficult to lock it, when I try to use the tower id I am not having much luck as when it locks I get no data and have to unlock it to be able to get data again.

Would it be easy enough to have a 'Lock Current Tower' button implemented into a future FW update? It would be a really cool and easy way for users to easily lock to a great tower when they find one.

Thanks :smiley:

Good idea, but if it was possible to just lock the base station we are using now, we would have done it in the first place. :rofl:
You can compare the data from the cell info after a successful connection with the data from the lock tower page……They don't exactly match. No PCI, TAC, etc. data in cell info.
So there is no way to simply use the current service cell info to lock the tower.

1 Like

I think it should be possible for this to work.

When the modem is connected to a tower, we can run AT+QENG="servingcell" and collect the following details:
5G: pci, freq, band, scs
4G: pci, freq

After retrieving those values, we can run tower lock with this command:
5G: AT+QNWLOCK="common/5g",<pci>,<freq>,<scs>,<band>
4G: AT+QNWLOCK="common/4g",1,<freq>,<pci>

This is how I tower lock my connections manually to the current tower.

If you have tower lock enabled, then the AX 3000 stores the configurations here: /etc/config/glmodem

2 Likes

Awesome, thanks for the info :smiley:

When I run the first AT cmd I get

+QENG: "servingcell","NOCONN"
+QENG: "LTE","FDD",234,20,CD6247,417,99,1,3,3,1812,-104,-13,-73,12,9,189,-
+QENG: "NR5G-NSA",234,20,928,-104,10,-11,641376,78,12,1

I think that these are some of what the values are:
+QENG: "NR5G-NSA",234(plmn),20(part of plmn?),928(pci),-106(rsrp),10(sinr),-10(rsrq),641376(freq),78(band),12,1

The other numbers don't look like they could be the SCS?

What info do I copy into the QNWLOCK cmd?

Thanks :smiley:

I didn't know you'd already thought of implementing this :melting_face:

If Will12345 reply works for me that will fix my issue I hope, maybe this could be turned into a button for everyday off the shelf users?

That one was a great tip, thanks @Will12345
Our developers are testing it and if it works, we'll add it to the new version.

1 Like


^ Documentation

5G: AT+QNWLOCK="common/5g",928,641376,30,78
4G: AT+QNWLOCK="common/4g",1,99,417

^ If it does not work, then you can reboot the router for tower lock to reset.

1 Like

Amazing, thank you, I'll give it a go, where did you see the scs value of 30? No wonder I couldn't work it out! Thanks again :smiley:

Edit, just ran the 5G AT cmd and I'm on the strong 5G tower I wanted (awesome!), how do I tell if it's locked or just wait to see if it drops?

The scs value is 1, so we need to convert that to kHz, which is 30. Documentation below.

1 Like

You can run this to get the 4G + 5G tower lock together: AT+QNWLOCK="common/4g";+QNWLOCK="common/5g"

The tower lock resets when the 5G modem is rebooted. So you need to save your commands and run them after every reboot.

1 Like

Gotcha! I read that in the document earlier but it didn't click in my sleep deprived brain, thanks :smiley:

Thanks again, will try this tip too. I will save the commands as suggested :+1: :slight_smile:

Hi, I've been using the AT cmd that Will12345 supplied for a couple of days now and my 5G signal has stopped flapping to 4G, I hope this 'button' does get implemented as it will help many users out there who struggle to lock their tower. Thanks for looking into this :+1:

1 Like

The results of testing by our developers also concluded that it works.
It will be added to future version.

1 Like

I saw that hes using NSA band for 5G which is not supported by the AT+QNWLOCK="common/5g" command so Im curious on what approach will the developers employ to "lock" those bands including the NSA. Afaik, NSA is highly reliant to 4G band.

When I run the command this is the results that I get:
+QENG: "servingcell","NOCONN","NR5G-SA","FDD",310,260,1832B6002,799,820500,125290,71,3,-103,-14,0,0,-

Even though it says that I'm connected as NR5G-SA, It looks more like a LTE signal doesn't it? It has all the data points of a LTE signal. Also, we recently had a storm that made the 5G signal super weak so I went to my local TMO store and asked them about it. They informed me that there were no problems with the towers but when I inquired about 5G SA, they informed me that there are zero towers in my area that even have 5G SA enabled. So how can this be if the router is showing 5G SA?

Here is the debug from when I run the cmd, you can see at the bottom it connects to LTE as my PCC and then the two SCC, one of which is the 5G I wanted, below that it says the EPS registration is successful so for me it seems to work as I'm on the tower I want and its not dropped.

{
"msgs": [
{
"cmd": "AT",
"result": "\r\nOK\r\n"
},
{
"cmd": "ATI",
"result": "\r\nQuectel\r\nRM520N-GL\r\nRevision: RM520NGLAAR03A03M4G\r\n\r\nOK\r\n"
},
{
"cmd": "AT+GMI",
"result": "\r\nQuectel\r\n\r\nOK\r\n"
},
{
"cmd": "AT+CIMI",
"result": "\r*\r\n\r\nOK\r\n"
},
{
"cmd": "AT+CPIN?",
"result": "\r\n+CPIN: READY\r\n\r\nOK\r\n"
},
{
"cmd": "AT+CREG",
"result": "\r\nOK\r\n"
},
{
"cmd": "AT+CSQ",
"result": "\r\n+CSQ: 27,99\r\n\r\nOK\r\n"
},
{
"cmd": "AT+GSN",
"result": "\r*
**\r\n\r\nOK\r\n"
},
{
"cmd": "AT+COPS?",
"result": "\r\n+COPS: 0,0,"3",13\r\n\r\nOK\r\n"
},
{
"cmd": "AT+QCAINFO",
"result": "\r\n+QCAINFO: "PCC",9360,50,"LTE BAND 28",1,174,-88,-12,-58,4\r\n+QCAINFO: "SCC",1392,75,"LTE BAND 3",2,249,-104,-18,-69,3,0,-,-\r\n+QCAINFO: "SCC",641376,12,"NR5G BAND 78",928\r\n\r\nOK\r\n"
},
{
"cmd": "AT+CEREG?",
"result": "\r\n+CEREG: 0,1\r\n\r\nOK\r\n"
}
]
}

common/5G only works on for SA band. Maybe the 4G lock helped your NSA get stable since it anchors on the correct 4G pci and band.

Not "highly", it IS reliant on a LTE (4G) connection.

I believe I have gotten AT+QNWLOCK="common/5g" to work on 5G NSA.

I don't remember the exact steps, but first you want to make sure network mode is AUTO so that the modem sees "everything" and also make sure 5G disable mode is disabled.

AT+QNWPREFCFG="mode_pref",AUTO
AT+QNWPREFCFG="nr5g_disable_mode",0

Next, run the 5G tower lock command

AT+QNWLOCK="common/5g",...

Finally disable 5G SA

AT+QNWPREFCFG="nr5g_disable_mode",1

You should be locked to 5G NSA at this point. You can also lock 4G tower if needed to keep 4G from switching around.