Spitz GL-X3000 SSH via 5G

I have a GL-X3000 with a T-Mobile Business Basic Mobile Internet contract, with the fixed IP option activated. I thought that that should give me a public IPv4 address on the router, but I only see 192.0.0.2/27. When I nmap the public address, I don’t see any open ports, even though I’ve opened SSH on the WAN interface (verified with iptables -L). However, running nmap from the outside to the apparent public IP does not show the SSH port open.

T-Mobile says that using our fixed IP we should be able to connect to the router. How can I proceed here?

Which IP do you get when you surf to a website like ifconfig.co?
This one should be the one you need.

That’s what I tried, and I’m not getting through. The IP on the status screen shows 192.0.0.2/255.255.255.224, which is not the right one, that’s why I am confused.

I just realized that the IP is changing every couple of hours, so T-Mobile is not giving us a fixed IP. I will check with them and report back.

1 Like

They might give you a static WAN address behind CGNAT. Which is great for security (like „login only from xy“) but useless for port forwarding.

T-Mobile uses IPv6 only, however they use 464xlat to translate between IPv4 and IPv6, which allows IPv4 devices/services to still work. So, you won’t have a public facing IPV4 address.

That is true for their regular consumer offering, but on a Business contract, you can get a public IPv4 address (for an additional $3/month), and that will allow you to talk to your router from the outside. We’re still waiting for T-Mobile to configure that feature correctly, right now we don’t have service at all.

T-Mobile is still trying to get us set up with a fixed IP.

1 Like

Spent over an hour on the phone with T-Mobile without a resolution.

The router only ever shows “SIM card not registered”. Are there any more specific diagnostics like a log file? And I’ve seen references to different modem device modes, is that documented somewhere, and would that make any difference? I.e. DUN vs. QMI0?

Can you enter the following AT command to get relevant information?
AT+QENG=“servingcell”
AT+QENG=“neighbourcell”
AT+CGDCONT?

AT+QENG=“servingcell”
ERROR
AT+QENG=“neighbourcell”
ERROR
AT+CGDCONT?
+CGDCONT: 1,"IPV4V6","b2b.static","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,1
+CGDCONT: 3,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1,,,,,,,,,"",,,,1
+CGDCONT: 4,"IPV4V6","tmus","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 5,"IPV4V6","h2g2","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 6,"IPV4V6","pcweb.tmobile.com","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0

OK

AT+QENG=“servingcell”
AT+QENG=“neighbourcell”
AT+CGDCONT?
AT+CGPADDR?
Double quotation marks are used in English mode
Don’t copy and paste double quotes

If I can, I will look at the problem through the goodcloud remote help, but you have to have other Internet access besides the modem
Technical Support via GoodCloud.tar (192 KB)

I have this working on a few routers. Once t-mobile enables the static ip you need to change the apn to b2b.static. all other cell settings can be left on defaults.
And yes, this does allow two way traffic, both inbound and outbound.