Spitz X3000 only connects to 4G or 4G+

I have 5GSA in my location. I am only 1 mile from tower.
But every time X3000 boots up, i get 4G+ or 4G connection.
My T mobile plan is for 5g
I have tried to use modem command : AT+QNWPREFCFG=“mode_pref”,AUTO
It will show 5gSA available but when i click on Autoconnect, it goes to 4G+

And every time i reboot, the above “mode_pref”,AUTO is not there. It goes to 4G instead.

Is this mode somewhere hardcoded within X3000?
I tried to look under /etc/config and /etc/rc.d for the scripts but couldn’t find out
Please let me know how to proceed and get 5GSA

mode is certainly not somewhere hardcoded

do you have poor performance? say: does a phone on 5G perform better than the phone via Spitz?

Upgrade the firmware on your modem.

1 Like


Try this

My phone gets 5GSA…band 41,25 with excellent DL and UL speeds
I am very close to the tower

I have the latest firmware (Jan 2024)

I am unable to see 5GSA bands


When i force a manual command: AT+QNWPREFCFG=“mode_pref”,AUTO (Set network search mode to automatic). Looks at the SINR…excellent. I also see band 41.


under Manual Setup option. I only see LTE bands.


When i choose the MASK option

Not the router firmware. Read the link. It is to update the modem firmware for the cellular modem.

Type in this AT command “ AT+GMR ” and compare the result to this “RM520NGLAAR01A07M4G”. If it’s not the same, then you will need to update the internal modems firmware.

See @packetmonkey comment above for instructions.

Is your module EM160R?
Use the following AT to view AT+QGMR

hello, do you have an environment for remote?

returning this router. no longer require support. apologies for inconvenience.

Also updated the modem firmware. Still same problem.

On a different note, i installed openwrt firmware from https://downloads.openwrt.org/
using uboot which wiped out GL.inet firmware

Next i used modemmanager for the network interfaces with the RM520N
To change bands etc, i used>> 4IceG (Rafał Wabik) · GitHub

Instantly 5gSA and 5gNSA bands with blazing speeds
No drop outs and every reboot the settings persisted

Although GL.iNET software is trying to make it easy for most end users, i believe
the shell commands in /etc/rc.d and /etc/init.d requires work and proper testing.

Many things are hardcoded inside the shell.
I like the hardware very much, but unsure about the software.

1 Like