Spitz X750 3.215 - Ubuntu 22.04 SSH connection (Solved)

Update my PC to Ubuntu 22.04 and while trying to SSH into the Router this error appears…

ssh root@XXX.XXX.XXX.XXX
Unable to negotiate with XXX.XXX.XXX.XXX port 22: no matching host key type found. Their offer: ssh-rsa

Seems this is due to SSH using rsa encryption and it now being considered weak, and has been for a while. It seems the Openwrt 19.xx uses an older version of SSH.

Is there any way of updating SSH on the Router?
GL.iNet X750 V4.X beta seems to have disappeared from the Repository, so can’t try that.

Any suggestions?

I feel that this leaves an attack vector of the router open for possible exploitation. ANy help would be much appreciated.

ssh -oHostKeyAlgorithms=+ssh-rsa root@XXX.XXX.XXX.XXX

You can add that to an executable file in /usr/bin/ and call it something like sshrouter and just type that in to connect, at least to address any connectivity issues with logging on with SSH.

1 Like

Thank you @Bitty_Bytes.

I can now connect, as it should! So easy when you know how, I had tried some things from the Internet, but none worked - probably me.

We still need that V4.X software to keep up with these security upgrades though!!