Spoofed Mac, yet Device name stay GL-MT-3000

I have the GL-MT300N-V2 (Mango ) router. And I have connected it to my Att gateway. Basically, I didn’t want anyone to find the devices I was connecting to my mango. But when I connected the mango to my att gateway, after that was when I logged into mango and i spoofed my MAC address. so, MAC address is successfully spoofed, yet when I login to the att gateway it still says default GL-MT300N-V2. I’ve reset the ATT modem. And at first it showed up as “User(Macaddress)”. But now that it’s been reset for a couple days. It’s showing the GL-MT300N-V2 as the device name again. I heard that the att ips saves the device name but the MAC address im spoofing was another smart device previously hooked up to the router. So I’m not sure what the problem is. Nope I can not go into the att gateway and change the device name, bevayse there is no option for that. I do have access to the administrator access for gateway tho. So now my room mate is like, I know you are hiding devices on the network because I looked up the device name and it’s a travel router from Gil.net. Does anyone know how to stop the device name from showing as GL-MT300n ?? Like I said, I reset the modem. This sucks, im spoofing the MAC address for a reason. But im not hidden when the device name shows. Help me… please.

Spoofing mac address does not change its name.

Its name is reported intentially. You can change that.

Try install luci, then change hostname first, then go to network and find wan, also change its name.

I haven’t done stuff like this in years, but I found a document that explains how to download luci if it’s not preinstalled on my modem when you say change hostname and go then go to network and find wan, im getting that those are settings within luci I can click on and change. So here goes nothing. Thanks for your help.

Oh so, I found another device MAC I could spoof, I don’t want to change the device name and my roomie see it’s the same MAC address and connect the mac with the new device name. So how should I do this so they never see the default device name connected with the new Mac or the new device name with the old Mac. Like how should I proceed as in order. If I disconnect while I do this would I even be able to click to change those things in luci?

How did you do? Can you post sceenshot?

Sorry I cannot understand this part.

We’ve got thee parties?

  • You (MAC1, MAC2)
  • GL.iNet Router
  • ‘roomie’.

You are using your device(s) to connect to the GL.iNwt router and you are fine. I assume tie GL.iNet Router ist connected to roomies network?
So your problem is, that roomie can see you’ve got two devices plus GL.iNet router? …

The question is: how does he/she/it knows?
Kismet/Airodump? Than find a larger Appartment or stop using WLAN. The router can’t hide what is floating around on the air (or ether).

Hi there. I’m having the same problem. So I did what you suggested, I installed LUCI. I changed the hostname to ring doorbell under “system” in LuCI. My ssid Wi-Fi name or whatever is already changed and “hidden”. So then I rebooted mango and I also rebooted my regular mesh router which is a tplink mesh and attached to att gateway. But, when I check “devices connected” (on tp link” it still says “GL-MT300N”. However, the MAC address is the ring doorbells MAC address. I agree with the op this defeats the purpose of MAC address spoofing. Because the name gives it away still. It’s the norm for the person I’m hiding this network from to check the devices on the network. Already she is suspecting foul play now that the “travel router” popped up on the network! I want to say hey, did you check the MAC address? It’s the ring door bell… weird…. But she has a mango too and she knows mango can spoof MAC addresses. And she will put 2 and 2 together and be like ahhhhh trying to spoof the ring door bell mac eh? Then probably check every single device that ever connects. SO. Please help, how do we change the name from showing up?

In firmware 3.x, in luci, you should go to network->interfaces and find WAN and wwan (repeater) interface. You will find that it has a hostname settings. Pls change that.