Spritz AX not connecting to T-Mobile 5G


I have two Spitz AX units. When I put a T-Mobile sim in they only connect on LTE band 66 or 12. If I exclude all LTE bands the units will connect to N41 but I get a sim unregistered error. If I put the same sim in my Suncomm SE06 Pro it connects to N41 no problem.

Has anyone experienced anything like this? The Spitz and Suncomm both have X62 modems. I have tried multiple T-Mobile some in both Spitz with the same result.

Thanks for any help.

@mikefromnj Hope will help you.

I just wanted to follow-up and say that this worked. I had to use the most current firmare for the modem from October. Once I upgraded to that, 5G NSA and 5G SA work. Thanks again

I just wanted to say I went through this process today. I grabbed the most recent (November 2023) version of the firmware and somewhat modified the instructions to account for a different filename than what was posted on GL-iNet’s upgrade page. Seems to be working fine for me. Just reboot the router when you are done and it should fire right up.


Where did you get the November firmware? The most recent o found was from October. Thanks!

It is possible the firmware inside is October dated, but here:

The top file shows a date of 2023-11-06.