SSD Doesn't Power On When Connected to MUDI

Had my MUDI about 24 hours now. Slowing working my way through many things. Decided to connect my external Samsung T7 SSD and immediately noticed that the normal indicator LED wasn’t illuminated. When I connect the T7 to my Note 9 or my Samsung Tablet using same USB-c cable, the LED is illuminated & both devices recognize it. I’ve already installed File sharing & Multimedia for the MUDI. File sharing via LAN & WAN are enabled, as well as share via DNLA. 98% on battery. Also did a full reboot while SSD connected. Lastly tried a different SSD (a T5) but still no power to the SSD.

Not sure what I’m missing.

Your SSD may need more power supply. Did you try connecting Mudi to a power source while having the SSD plugged in?

I haven’t tried that and believe I would need a USB-C hub with power pass through to connect both the SSD & power at same time. Again, both my Samsung Note 9 & my Samsung Tablet have no problems powering the SSD. With the size of the battery in the MUDI, I can’t image the SSD would require more power than what my cell phone & tablet provides.

Mudi limits the power output of the USB port to ensure the battery can power up the 4G LTE modem successfully. You can get only 0.7A or less from the USB port. It might able to charge smart phones when it’s not working as a router.

That’s interesting especially since GL.iNet writes “You can use an external USB storage or a MicroSD card with GL.iNet router, and some models have big internal storage.” Source: Applications - GL.iNet Docs.

The good news is that I just connected my Satechi Aluminum Multi-Port Adapter V2 - 4K HDMI (60Hz), Gigabit Ethernet, USB-C Charging, SD/Micro Card Reader and now the SSD’s LED is illumated. I will test whether or not I can actually access the content of the external SSD connected via the hub.

For a device that has won so many awards, IMHO the inability to power an external SSD is a glaring ommission or design failure. I have a 7 year old RavPower MD02 with a much smaller battery that can power the same SSD, accept multiple clients, stream media to mutiple users, etc.

Thanks for the input panpan.

Well, I need to clean my glasses. I didn’t notice the normal USB slot next to the USB-C port, that or I had tunnel vision. Anyway, I just connected my SSD to the MUDI using the normal USB port & the SSD is responding. I was able to immediately see & access my data on the SSD. Path is: \gl-e750\GL-Samba\Samsung_T5.


If your computer does not show any signs of life after powering on, or if it shuts down immediately, possibly beeping (i.e. not even making it to the operating system boot point), the problem is most likely to be hardware based. The SATA interface is used to connect the SSD to the computer today. However, SSDs intended for use with mSATA, M.2 or PCI-Express slots must be plugged into their slots. If RAID DATA RECOVERY fails, you must select “MBR” or “GBT” in the drive initialisation.