SSH access to GL-MT300N-V2 via WAN

I am using GL-MT300N-V2 with the default firmware (version 2.271) and would like to have SSH access to the device via WAN.

The WAN access is activated on and I am in fact able to access the web-interface via WAN, but the SSH connection is being refused (works fine from the LAN side).

What should I do to enable the SSH access via WAN?

ok, what I’ve now done is completely disabling firewall via
service firewall stop && service firewall_gl stop

Tried to figure out /cgi-bin/luci/admin/status/iptables first, but there are virtually just two buttons there: Reset Counters and Restart Firewall

@eugrus Please ssh to the router. Add the following lines to /etc/config/firewall.

config rule 'ssh_rule'
	option name 'ssh'
	option dest_port '22'
	option proto 'tcp'
	option src 'wan'
	option target 'ACCEPT'
1 Like