SSH password reset!

I am using a GL-iNet 4G Smart router.
“Unfortunately” i flashed a new firmware. And after that i am not able to get the WebUI.
It looks like the http server is not available on the new firmware and i need to install the same.

So i tried to ssh to root@
But, the default password is not working. Is there any way to reset the password ? or anyway to get back my webUI ??

Download the latest version of the Mifi firmware here:

And flash it this way:

Let me know how it goes :slight_smile:

As mentioned in the link, i pressed the reset button, then powered on the device. The top most one on the 4 LEDs on the leftside of the router started blinking after 10 seconds.

After that, i tried to ping after setting the IP address on host. It did not work. Ping failed.
i.e the WebUI of is not working in my case.

So, i set the ip address of host to DHCP and it got as the ip address. And i was able to ping

Then i tried to ssh, but could not login yet.

You are doing it wrong.

  1. press and hold the reset button
  2. plug only one cable to the lan or wan
  3. power on the device.
  4. one led will start to flash. After 5 times, another led light up. Now release your finger. Don’t hold it until 10 times led flash
  5. now set your pc’s IP and you are able to access for uboot failsafe.

Hi Alzhao,

this is what i did.

on the 4gsmart router, i pressed the reset-button. Then connected the LAN cable with my ubuntu host machine.
Then powered on the device. The Power-on Indicator and 4 LEDs were on. And the top-most LED among the 4 started blinking.
I counted this for 5 seconds and there was no change.

The ipaddress is getting configured properly using DHCP. and i am able to ping to
but, to ssh and to login…the password issue !!

I think you want to factory reset. Holding the reset button great than 8 seconds and the release. It should be work.

I am confused. If you are doing this when the router is powering up, it tries to enter uboot web failsafe. it will never allocate IP address.

Seems openwrt boot already. There is no password if you never configure one. ssh just takes no password for root.

You can also try telnet

So just to add to the procedure.
Turn off the Mifi.
Connect a lan cable from another router/pc to the Lan port on the Mifi.
Press and hold the reset button, and at the same time power on.
Do not release the reset button.
The 4G led will blink 1 time. Ignore that blink
Now it will blink 5 times.
Exactly on the 5th time release the reset button.
You will see the 4g light blink 3 times rapidly.
This means you have done it correctly.

If you don’t get the 3 rapid blinks confirmation, then try again.

Then you follow the guide as before, setting a static Ip in your case in ubuntu.
The router will not give you an IP automatically, you must set it manually.

Thats the problem i am facing.
i tried ssh root@ and it asked for password.
When i tried “goodlife”, it says permission denied.
I did not set any other password too !!

Factory reset with 5/8/10 secs of pressing reset button is not helping here.

Its not that easy for my router.
Even after factory reset, it is still asking for ssh password.
and i dont get a webGUI too !

I saw the 4g LED blinking once. And after that it did not.
the top one on the 4 LEDs on the leftside is blinking.

Now i suspect, i lost the board !!! i am confused if the firmware i have now is the right one or not !!!

The LED’s on the left side are just the charging circuit and they have nothing to do with the system itself. Blinking top one means its charging from 75% to full and not fully charged.

then the factory-resetting is not working on my box !!
All i see is this charging unit which is blinking…and nothing else.

Maybe you have a faulty unit then :frowning:

Can we go back the the beginning?

You flashed a firmware making it not working, you need to flash the firmware back. It doesn’t work with ssh or telnet.

As Johnex said, you need to use the following method to change back the firmware. It is uboot web failsafe mode. It doesn’t work with ssh, ping and telnet.

But the u-boot webUI is not working for me either.
i am not able to access
I am able to ping it. But no webUI.
thats why i thought, i will try login in ssh prompt and try to see if there is luci…or to install it.

You’re wrong. Have you read the guide? Debrick via Uboot - GL.iNet Docs

BTW, you should access, not https, it doesn’t support https on u-boot webui.

Oops. .
its a typo out of habit !
I was not using https. It was always http.

uboot of this model should be quite stable. There must be some thing wrong in the procedure.

Can you bother to make a video of what did you do?

Like @alzhao said, make us a video so we can see exactly what is going on.
If you have no LED’s just the charging ones then there is something wrong if you are doing the procedure correctly.