SSID changes to HT-AP#


I’ve been having this issue with my router. The SSID name changes to HT-AP#, after avery disconect and reconect to a power source.

It’s odd, because it may indicate that a package is missing for SSID in the firmware or it might have been corrupted. I’ve reset the firmware several times and the same issue occurs.

It’s like clockwork, I can configure the unit, leave on, upplug it and replug it into a wall outlet and it will always change the SSID to HT-AP#. This is independent of the band being used.

Is there a reason for this or fix for this issue?

Which router model and firmware version do you have? Can you post a screenshot of the HT-AP# SSID?

I do not work for and I am not directly associated with GL.iNet

In short, it is connected to 802.11s (Mesh). I think it is a visible SSID, that should not be visible.
I would reinstall the Firmware without keep the settings.

Do you mean MT1300?
Which firmware?

HT-AP# is the default SSID if you set up multiple VAP in the router.

For example, the first and 2nd SSID is GL-MT1300-xxx and GL-MT1300-xxx-guest. If you make a 3rd or 4th SSID and didn’t set up correctly, the SSID will be HT-AP#.

So I wonder if you can give more details to investigate this issue. e.g. firmware version and your detailed setup.

The firmware is 3.2.11.

Yes, the main networks can hide their SSIDs. However, this was the guest networks I configured.

Hopefully, one day a guest networks can be hidden as well. Would you what script would fix this? Or is it firmware issue?


I would like to believe your statement; but in fact, I did set up the SSIDs properly for the guest networks. Tipically, you are to use the main networks for security reasons as most modems once on the main network you or an attacker can log into the router. So, typically, I use the guest network.

In this scenario, the it was the guest networks that would default to HT-AP### SSID. Is there a special script in any firmware that prevents this from occurring?

  1. log in and change the password
  2. turn off all the networks
  3. change the IP
    login agian
  4. set up other features
  5. setup tor
  6. configure the network

The real issue with those network names changes is that the internet no longer is accessible. So, in fact, it may be linked so another feature as opposed to the network names. This is very likely an isolated case.

Maybe, I should message you via this forum.


Maybe you can just try 3.215 snapshot. A lot of bugs fixed in the wifi driver.

Thanks, I’ve tried it for a little while and it seems to work. The Access point does not revert to AP###, The access point name remains the SSID I’ve selected during configuration.

The only issue I’ve noticed now is that the device does not switch from repeater to router or vice versa automatically; consequently, you cannot connect to the internet. But that’s fine. As long as the access point name is the SSID.

I’ll pay close attention to device switching modes and reply in a few day.

Thanks for the suggestion.

Really? The failover should work because nothing changed.

Yes, the fail over does work. When you unplug while in a repeater mode and replug the device into an outlet. Repeater to repeater is Ok.