SSIDs from GL.iNet GL-AR750S-Ext aren't visible from Linux or macOS

I got the router yesterday. I configured it as a WiFi repeater using 5 Ghz on both ends, and I managed to connect my Android 12 phone, Ubuntu laptop and MacBook Pro. Everything worked as expected.

I’m trying to use it today, but neither Ubuntu or macOS can see the SSID of the router any more. All other nearby networks are listed, and I can connect to the “source” network just fine. Only my Android phone can see and connect to the GL.inet router’s network (and access the Internet).

I just did a factory reset using the hardware button, but the issue persists with the default SSID: Android can see and connect to the GL.inet network, but Ubuntu and macOS can’t.

Any idea what’s going? Thanks.

OK, it seems like I can connect to the network if I manually enter the SSID as if it were a hidden network – which it’s not, as Android can see it.

That worked on Ubuntu. I’ll try it later on macOS.

Any idea how to avoid this?

Seems it is weird. You can try changing the channle and encryption and try again?

Try setting wifi to HT20, if router not already set to that channel bandwidth.