Stock Firmware Slowing Things Down?

Can you post a photo and put up some details, please.

Ok, I’ve spent some time with it this evening.

I found out that one of my issues was that I was trying to help some people and had my router using the USB3 setting. Setting it back to the default value gave me back some speed, but it is still significantly slower using stock firmware

I tested every band combination that I can access on AT&T with my EP06-A card at my location on the GL-iNet firmware, but I didn’t test every combination on the ROOTer Golden Orb, because I’m missing something with the band changes in that firmware. Every time I change the bands, I have to reboot to get a connection, and frankly it was taking too long for each combination.

A typical example is my results from Band 4:
GL-iNet firmware = 47.97Mbps
ROOTer G O = 90.53Mbps
47% slower on stock firmware

Using my fastest CA combination, 5 and 66:
GL-iNet firmware = 66.34Mbps
ROOTer G O = 98.92Mbps
33% slower on stock firmware

If I’m not mistaken, the GL-MiFi has a 100Mb ethernet port, so I think I’m being bottlenecked by that port at this point. I would be perfectly content to be limited to 100Mbps, but I’d rather use the GL-iNet firmware because I really prefer that interface.

This kind of performance hit, though, will keep me on the other firmware

This is very strange. I will have a test in my side.

I can confirm seeing similar results

Thank you for helping confirm that it’s not just me.

Which modem are you using? I’m using an EP06-A. I’m wondering if it affects more modem cards.

Can you try disabling GLTertf and see if it gets better?

@Tanbam I am also using an EP06-A

Seems it is QMI mode problem. The default firmware seems to have a problem with QMI.

I used China Unicom and filled APN directly into the Rooter. After reboot the device, the modem was successfully connected to the Internet, but the speed was no more than 1M.
In the same environment, I used GL firmware and clicked Auto Setup to obtain a speed of 20M.
In Rooter, do you have any particular configuration?

TanBam I believe I was the one that was talking about the speed difference between glinet and goldenorb on my x750 it is a huge difference glad that you see it as well

the load balancing is so simple and if you go to the forum they are quick to help and they are great guys. I asked all sorts of dumb question that us newbies ask and they were more then helpful and never gave me a hard time about being new to to os

Alzhao strange or not its a fact and I like the GUI of glinet but the speed difference when I have 20+ devices connected keeps me on goldenorb I check every day for the 19.0 firmware update hoping that will make a difference

luochongiun, no, I don’t use any special configuration. I just set the APN and go.

I do think it’s an issue with the GL Firmware and QMI mode with Visible/Verizon. (I don’t have another provider to test with)

I just did a few speed tests with both locked to Band 66.

Tried & got the same issue

Are you planning to look into the issue ?

We tried ROOter firmware here and it is lower than our stock firmware. I don’t have an idea.

Can you check if in the stock firmware, you are using QMI? BTW, we added ncm protocol for Quectel modems which should work better.

We are also made changes to the hardware of Spitz and it will have great improvement in signals.

That doesn’t really help those who have bought it.

Tried QMI & MBIM - how do I enable NCM to try it?

I still don’t understand this router - I get like 40mb upload consistently and download struggles at 20mb.
It’s a CAT 6 Module, apparently, should be achieving much, much higher speeds than this.
My Samsung S5 is CAT 6 AFAIK and it gets 100mb down and 50mb up - What’s the deal with this thing?

Extremely frustrating piece of kit.

I optimized 4G->WIFI forwarding rate, please download the firmware test here

1 Like

I’d love to try it, but I only have GL-MiFi and MUDI devices.

If you can whip up a firmware build for those, I’d test them out for you.