Strange behaviour observed with stubby on flint and youtube


So I’m using firmware 3.207 (compile time: 2021-11-29 22:17:00) with flint downloaded from the testing folder.

now its known with this build that sometimes stubby needs to be manual restarted because of sudden loss of connectivity to the dns, but now I’m confused.

When I go to youtube, it keeps saying I have no internet, but I’m able to resolve other domain names even unknown ones, I tried to restart the browser, cleaning all history, even tried using a different browser but nope youtube keeps giving me the same error.

however, my dns works… the only solution how I got it fixed is by rebooting the router, stubby -g does not work for me on youtube only for other sites it does.

what does youtube different than other domains and gives stubby a malformed response?

this was pretty confusing, if someone can help me or know its a bug please let me know.

I just tried NextDNS and it works fine with youtube.

I wonder if you have set any Denylist of Allowlist??

1 Like

Yes I had enabled many blocklists I think I might found the tracker, it was called, I will test a little further.


It seems to work, thanks :+1:

1 Like