Successfully installed USB Wifi just doesn't work? MT300N-V2

Hello,

I have read through every info i could find. But after almost three days of frustration i have to ask for help.

The aim is to add a Wifi dongle (TL-WN722N v1) to a GL-MT300N-V2-ab1 which should connect to a existing AP via a high gain antenna and extend the internet through the internal wifi device.

It seems the drivers (kmod-ath9k-htc) are installed correctly when i look at dmesg right?

[ 24.037798] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[ 24.045381] usbcore: registered new interface driver ath9k_htc
[ 24.550536] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008

Then

rm -f /etc/config/wireless
wifi config

After it the new radio0 appears in my wireless config file as it should.

And now i have no clue what to do next. I wasn’t able to do anything with radio0. Whatever i do in /etc/config/wireless the new Wifi dongle doesn’t do anything. The light doesn’t even turn on or blinks.
When i install travelmate. I can use radio0 to scan networks. But other than that radio0 stays silent :frowning:

The Wireless tab in LUCI is not there. So how do i set things up?
This is how my wireless config looks like:

config wifi-device ‘mt7628’
option type ‘mt7628’
option htmode ‘HT40’
option ht_txstream ‘2’
option ht_rxstream ‘2’
option hwmode ‘11g’
option noscan ‘0’
option txpower ‘20’
option txpower_max ‘20’
option country ‘US’
option region ‘0’
option band ‘2G’
option mimops ‘3’
option wmm ‘1’
option channel ‘10’

config wifi-iface
option device ‘mt7628’
option network ‘lan’
option mode ‘ap’
option encryption ‘psk2’
option key ‘goodlife’
option ssid ‘GL-MT300N-V2-eb1’
option wds ‘1’
option disassoc_low_ack ‘0’
option ifname ‘ra0’

config wifi-iface ‘sta’
option device ‘mt7628’
option network ‘wwan’
option mode ‘sta’
option ifname ‘apcli0’
option ssid ‘Airtel-E5573-5656’
option bssid ‘98:9C:57:28:56:56’
option channel ‘10’
option encryption ‘psk2’
option key ‘h4442372’
option disabled ‘0’

config wifi-device ‘radio0’
option type ‘mac80211’
option channel ‘11’
option hwmode ‘11g’
option path ‘platform/101c0000.ehci/usb1/1-1/1-1:1.0’
option htmode ‘HT20’
option disabled ‘0’

config wifi-iface ‘default_radio0’
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ssid ‘OpenWrt’
option encryption ‘none’
option ifname ‘apcli0’

Network config:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fdf9:bc04:96db::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option hostname ‘GL-MT300N-V2-eb1’
option ipaddr ‘192.168.8.1’

config interface ‘wan’
option ifname ‘eth0.2’
option proto ‘dhcp’
option hostname ‘GL-MT300N-V2-eb1’

config device ‘wan_dev’
option name ‘eth0.2’
option macaddr ‘e4:95:6e:44:2e:b1’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’
option disabled ‘1’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘0 6t’

config interface ‘wwan’
option proto ‘dhcp’
option metric ‘20’

Interfaces:

Wireless Overview:

I have read that people did this successfully. But how? How do i use/activate the new USB dongle? I couldn’t even manage to see the MAC address of the WIFI dongle in Network -> Interfaces. Even when i change mt7628 to radio0 in the wireless config. Why??

For any help i would be happy to donate some money.

Thank you
ED

P.S.: In the config files i deleted the guest interfaces to make this post smaller and easier to read.

Can you pls check if your wifi network device is wlan0 other than apcli0. Apcli0 is for the internal wifi driver so it is wrong for sure.

Pls ty using ifconfig -a to check network devices.

ifconfig -a gives me this output:

root@GL-MT300N-V2:~# ifconfig -a
apcli0 Link encap:Ethernet HWaddr E6:95:6E:04:2E:B1
inet addr:192.168.6.101 Bcast:192.168.6.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

br-lan Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
inet addr:192.168.8.1 Bcast:192.168.8.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:115666 errors:0 dropped:0 overruns:0 frame:0
TX packets:125209 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:31041154 (29.6 MiB) TX bytes:70980724 (67.6 MiB)

eth0 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
inet6 addr: fe80::e695:6eff:fe44:2eb1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:95893 errors:0 dropped:4 overruns:0 frame:0
TX packets:134102 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:30759864 (29.3 MiB) TX bytes:67239399 (64.1 MiB)
Interrupt:5

eth0.1 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:95590 errors:0 dropped:9 overruns:0 frame:0
TX packets:132366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29016993 (27.6 MiB) TX bytes:66111738 (63.0 MiB)

eth0.2 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1722 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:588924 (575.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:6524 errors:0 dropped:0 overruns:0 frame:0
TX packets:6524 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:681416 (665.4 KiB) TX bytes:681416 (665.4 KiB)

ra0 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:86601 errors:1031 dropped:0 overruns:0 frame:0
TX packets:32773 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8753143 (8.3 MiB) TX bytes:10491983 (10.0 MiB)
Interrupt:6

ra1 Link encap:Ethernet HWaddr E6:95:6E:54:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ra2 Link encap:Ethernet HWaddr E6:95:6E:64:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

teql0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wds0 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wds1 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wds2 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wds3 Link encap:Ethernet HWaddr E4:95:6E:44:2E:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

I only see the MAC addresses from the internal device. Shouldn’t there be the USB Wifi be listed as well?
Not sure if this info helps, but it shows up with lsusb:

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0cf3:9271 Qualcomm Atheros Communications AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And also with lsmod | grep ath9k

ath 17427 3 ath9k_htc,ath9k_common,ath9k_hw
ath9k_common 11725 1 ath9k_htc
ath9k_htc 54051 0
ath9k_hw 337100 2 ath9k_htc,ath9k_common
cfg80211 212996 4 ath9k_htc,ath9k_common,ath,mac80211
compat 667 4 ath9k_htc,ath9k_common,mac80211,cfg80211
mac80211 411999 1 ath9k_htc
usbcore 126129 23 ath9k_htc,option,usb_wwan,sierra_net,sierra,rndis_host,qmi_wwan,huawei_cdc_ncm,cp210x,cdc_ncm,cdc_ether,usbserial,usbnet,ipheth,cdc_wdm,cdc_acm,uas,usb_storage,uhci_hcd,ohci_platform,ohci_hcd,ehci_platform,ehci_hcd

Thanks for your reply. If you can help me get it running. 10USD to a donation of your choice :slight_smile:

Can you change this and restart your device and check again? Seems the device need to be configured to appear.

Pls try the following to see if you can list the wifi device.

iw list 

OMG. It worked!! It feels so good after three frustration days :smiley: :slight_smile:
You my hero of the day. Of the week actually :smiley:

wlan0 appears in ifconfig and i even see the new Wifi so now i can play around now to achieve my main goal. I am serious about the donation. So if not for you. Any other project or Patreon of your wish.

You can donate to charity. What we need is just a 5-star view on Amazon. That will be very helpful.

1 Like

If you are still there and doesn’t take too much of your time. Can you give me quick instructions on how to set radio0 to connect to a existing AP via high gain antenna and the internal wifi device should be the AP.

5 star review it is. And I will even buy another one if it all works :slight_smile:

1 Like

If you want to configure sta using ardio0, you need to disable the original sta. Pls check the highlighted config below.

Then you need to add the following

config wifi-iface ‘sta1’
option device ‘radio0’
option network ‘wwan’
option mode ‘sta’
option ssid ‘Airtel-E5573-5656’
option encryption ‘psk2’
option key ‘xxxxxxxxx’
option ifname ‘wlan-sta’
option channel 'xx’

About channel, you may not need this. But if sta cannot be connected, pls add channel information.

1 Like

I changed as you mentioned. And it seems to work. But only for a few seconds. After that the wireless config resets automatically to the old one using sta.

This is my wireless config before the change:

config wifi-device ‘mt7628’
option type ‘mt7628’
option htmode ‘HT40’
option ht_txstream ‘2’
option ht_rxstream ‘2’
option hwmode ‘11g’
option noscan ‘0’
option txpower ‘20’
option txpower_max ‘20’
option country ‘US’
option region ‘0’
option band ‘2G’
option mimops ‘3’
option wmm ‘1’
option channel ‘10’

config wifi-iface
option device ‘mt7628’
option mode ‘ap’
option encryption ‘psk2’
option key ‘goodlife’
option ssid ‘GL-MT300N-V2-eb1’
option wds ‘1’
option disassoc_low_ack ‘0’
option ifname ‘ra0’
option network ‘lan’

config wifi-iface ‘guest2g’
option device ‘mt7628’
option network ‘guest’
option mode ‘ap’
option wds ‘1’
option ssid ‘GL-MT300N-V2-eb1-Guest’
option encryption ‘psk2’
option key ‘goodlife’
option ifname ‘ra1’
option disabled ‘1’
option guest ‘1’
option disassoc_low_ack ‘0’

config wifi-device ‘radio0’
option type ‘mac80211’
option channel ‘11’
option hwmode ‘11g’
option path ‘platform/101c0000.ehci/usb1/1-1/1-1:1.0’
option htmode ‘HT20’
option disabled ‘0’

config wifi-iface ‘default_radio0’
option device ‘radio0’
option mode ‘ap’
option ssid ‘OpenWrt’
option encryption ‘none’
option ifname ‘wlan0’
option network ‘lan’

config wifi-iface ‘sta1’
option device ‘radio0’
option network ‘wwan’
option mode ‘sta’
option ssid ‘Airtel-E5573-5656’
option encryption ‘psk2’
option key ‘XXXXXXXXXX’
option ifname ‘wlan-sta’
option channel ‘8’

config wifi-iface ‘sta’
option device ‘mt7628’
option network ‘wwan’
option mode ‘sta’
option ifname ‘apcli0’
option ssid ‘Airtel-E5573-5656’
option bssid ‘98:9C:57:28:56:56’
option channel ‘10’
option encryption ‘psk2’
option key ‘XXXXXXXX’
option disabled ‘1’

I don’t know if that’s the real reason behind. But instead of disabling sta in the wireless config i deleted the whole config wifi-iface ‘sta’ section.
Now it seems to work. Already since 30min without problems. Thanks again. Amazon review it is. Great device. Nothing for noobs but good service = 5 star

1 Like

The router has a repeater manager which continuously try to reconnect using the old config. So after you remove it, it should work fine.

Thanks for your review.

1 Like