Sudden dead LAN port on MT3000

Last week I purchased a GL MT3000. The following incident happened about 24 hours after receiving the router.

The MT3000 was working great (connected via a LAN cable) and I’d been online steady for 2-3 hours when suddenly (i.e., w/out any fiddling with settings) the connection was lost. I investigated and discovered the LAN port was not working.

I tried jiggling the cable on both connections, replacing the cable with a different one, checking the connection port on the computer (w/ a WAN connection), and finally resetting the firmware. After resetting (and accessing the MT3000 via WiFi), I carefully checked all the settings and even tried setting the WAN port to a LAN (and then back). The LAN port was dead. Yet everything else worked fine.

Unfortunately, I forgot to check the log file in time and, now, there are no entries for the time that the failure occurred.
The firmware is version 4.4.6.

Thank you, in advance, for any assistance.

Hello, is the LAN port of your device working normally now?

The support team contacted me and I ended up getting a replacement, which now works fine.