Surfshark Wireguard not connecting

Hello to all.
Recently the router has been updated to kernel Firmware 4.1.0, kernel version 4.4.60 and OpenWrt 21.02-SNAPSHOT r16399+157-c67509efd7.
I had to configure everything again.
Previously I had a Wireguard configuration for Surfshark that worked perfectly.
Now I have uploaded the configuration again and the router comes up with the following message in the connection logs:

Fri Jun 23 08:21:42 2023 daemon.notice netifd: Interface ‘wgclient’ is now down
Fri Jun 23 08:21:42 2023 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Fri Jun 23 08:21:42 2023 daemon.notice netifd: wgclient (15208): Name does not resolve: `es-mad:51820’

I have opened a case in Surfshark, to see if it is an FQDN issue, in the meantime I don’t know if it is due to a missing packet.
I have checked the list of packages in Luci, and I have seen that some of them were missing, I have installed them and I still have the same error.

Do you know what could be the cause?

Thanks in advance

Yes…The problem is that today if you downloaded .conf files from Surfshark they sent you an incorrect endpoint in the file…

You can edit your .conf file and ensure it is in the following format…
This is for Las Vegas but use it as an example.
Most likely the endpoint in your file looks like this us-las:51820
So edit your file’s endpoint to include the missing section
Once done with the edit save it and reload it in the VPN Client setup.

I encountered this today when reloading conf. files trying to troubleshoot their screwed up Wireguard
connections…Fortunately for me Wireguard is currently working again correctly (They either fixed their
networking issues or reverted to a previous configuration).

Good Luck

Hi @motox22a
Many thanks for your answer. Yes! you were right!
I changed to, and it works perfectly.

Have a nice day.

Hi @motox22a

Could you kindly explicate more in details please, as I’m also facing the same issue cannot get the VPN to connect on surfshark Wireguard.

Many thanks in advance