Switch switch0 has an unknown topology - the VLAN settings might not be accurate

I have GL-AX1800 with v4.2.0 beta 2, configuration factory resetted.

Going into OpenWRT → Network → Switch, it shows:
Switch switch0 has an unknown topology - the VLAN settings might not be accurate.

Could VLAN be normally function?

I have two ISP on eth0 and eth1.
I am trying to route traffic to eth0 and eth1 according to source LAN IP.

Thanks.

that is why I removed the switch section in /etc/config/network, switch actually doesn’ exist I think

I have read your files.
Are you using dual WAN with load-balance or failover?
I don’t need load-balance or failover.
I just want to route by LAN IP.
Thanks.

They are for failover but then you can switch mode from gl.inet interface or advanced luci load balance interface setting the same metric (and weight if you have different bandwidths) parameter. Furthermore my setting is for AXT1800 while you have AX1800 so I could be wrong. Better to ask a gl.inet member…

I have made these commands to route 192.168.50.10 through eth1 (ISP-B):

ip route add default via $(ip -4 addr show eth1 | grep inet | sed 's/.255/.1/g' | awk '{ print $4 }') dev eth1 table 100
ip rule add fwmark 100 table 100
iptables -A PREROUTING -t mangle -s 192.168.50.10 -j MARK --set-mark 100

Usually I do from Luci interface, firewall NAT rules like this:

May I know how to set

iptables -A PREROUTING -t mangle -s 192.168.50.10 -j MARK --set-mark 100

on LUCI?

Thanks.

swconfig dev switch0 show

show the detailed switch config.

This is luci. There is a warning message but the switch config is fine