Sync timezone issue on Beryl 1300

I have: Baryl 1300, firmware version 3.216. Recently moved to a different timezone. When i log in to the admin panel and try to sync timezone I get error: “The parameter contains special characters ‘&|,…’”. Also, tried to manually select the right timezone from the drop down menu and click ‘apply’ - same issue. If I select UTC and click ‘apply’ it works. Only issue for some timezones. I did try to revert firmware - didn’t help.

Any idea what I need to do to sync timezone?

Attaching screenshot below:

The browser time is out of sync. Update your local system time on your computer to your new timezone. Close out of your browser and try again.

The browser time is correct. I also tried to do this via the mobile app - I get a different error, error code: -33.

How odd. The first thing I’d check is that the Network Time Protocol (NTP) dameon is running.

  • GL GUI → System → Advanced Setting → LuCI → System → Time Synchronization
  • LuCI → Status → [Search for “ntpd” via your web browser’s functionality]

LuCI’s passwords is the same as GL GUI.

1 Like

Update to the newest firmware 4.3.7. To rule out any issues with the firmware.

1 Like

Great. Thanks for all the feedback. I was able to sync time by following suggested steps: * GL GUI → System → Advanced Setting → LuCI → System → Time Synchronization

1 Like