T-Mobile Wifi calling NOT working

I bought a new GL-X3000 and installed a T-Mobile SIM card. We use it in our RV while camping.

The data works great. Speeds up to 200+ so no issues there. However, I cannot make/receive any calls on my IPhone (via Wifi calling). What is weird, is that my Android (Samsung) phone works.

I tried to turn on IPv6 and that did not help, other than drastically slow down my data speeds.

Any tips or recommendations to have Wifi Calling on my IPhone with T-Mobile? TIA!!!

Have you tried to enable VPN on that Router and try to test with VPN on ?

1 Like

No, I did not. Sorry for the dumb questions, but what is the best way to enable the VPN and which options should I use? I played around with a few options but could not get past the login window. I do not know the username. I assume the password is the admin password for the X3000 router.

Thank you!

Actually you don’t need to enable the vpn as it might cause additional issues !

If your android is working fine then you may need to disable the WiFi calling and enable it again on your iphone so that it can register the phone to T-Mobile.

Try this, it should fix the T-Mobile WiFi calling UDP packet issue and has also been known to fix some VPN’s that use UDP packets. I have shared this document on two facebook cell groups, with Cody and they put a fix in on the firmware for it, InvisiGig also put a custom APN fix in place on their firmware based on this document. And yes I have done these changes on the modem on the Puli-AX to get WiFi calling working on my T-Mobile home internet.

I found the easiest way to make changes to the modem like with these instructions is to use Minicom. I installed Minicom from the advanced menu software section.
Turn on SSH to the router
Connect to the route with ssh and run the following:
minicom -D /dev/ttyUSB2
Then do control A then E to turn on local echo
Type ATI for a test

These instructions have been tested by multiple users and routers that all have the RM-520N modem with success on different routers. I have personally tested this on the Puli-AX, Cody P5, InvisiGig, and Suncomm routers that I own.

Please note that I am the author of this document. I try to keep this up to date on the three forums I belong to but it’s not as easy to do on this site. I only ask that you share a link to the document and don’t share the document itself in case I need to make any changes to the procedure for this fix. Thanks, Scott

T-Mobile WiFi calling and VPN UDP packet MBN Fix.zip (36.2 KB)

1 Like

T-Mobile is known to block hotspots, or any peculiar connections to their network, so a VPN is the only way to bypass those restrictions. I have run into those issues when using iPhones while Androids work just fine (like remote play and such). A low ping VPN or a VPN over VPS is usually what makes it work.

Huh. I have a Wireguard VPN I use with my SpitzAX on a T-Mo (US) “Unlimited” $20 Tablet plan that works perfectly, but now I’m curious. I’d read the .PDF, but I’m not sure what it’s actually fixing - do you have any further Technical details about what’s going on?

(ETA: do you have that .PDF as a text file, so I can cut-n-paste the text?)

1 Like

Well in short it was a problem with how T-Mobile has the APN (or MBN) profile on the modem set up and how the modem is handling the UDP packets to sometimes get truncated. Same thing has been known to happen with some VPN’s using UDP if the MTU is not adjusted to cover the overhead of the packet to allow the stack of the encryption part. Because WiFi calling is all based on UDP packets this seemed to have caused this issue. As for the VPN, some have an issue with it disconnecting and some don’t. I can’t remember what VPN’s it helped, but I know it’s helped some of them. Now if the VPN is using TCP or HTTPS then you wouldn’t notice an issue.
It does seem to be specific to the RM520N modem. But the RM502 years ago had a similar issue as well.

@ScottD Thank you so much for the proper fix for this! WORKS PERFECT NOW. I have the Spitz GL-X3000 and was able to get WiFi calling working properly on my router with the following command: AT+QMBNCFG=“Select”, “ROW_Commercial”
I suppose each sim card is different and it would be difficult for the programmers to know each and every use case but I tested it with the Generic settings you described in your article and it worked as well. I think that GL.iNet programmers could easily implement this fix for their X3000 routers.
Again, thank you and I can finally start using my VPN using the Global Proxy instead of the Custom Routing rules that I had to have enabled prior to this fix.

If I use your Generic settings it only allowed the modem to connect to 4gLTE. With “Row Commercial” I can connect to 5G SA towers.

1 Like

Do you mind sharing?

Your welcome.
It probably only allowed you to connect to 4gLTE because you still have to add you APN. If GL.iNet did the APN adding according to the standard then it would have appended your APN to the bottom of the generic MBN profile.
I know cuddy was following me with the issue and added a special check mark for the fix. When I looked at it the GUI check mark just did what I wrote out manually. It good to know the X3000 has this option, NOW if only GL.iNET would put that standard across the board because I have a PuliAX and it does NOT have that option check box in the GUI, errrrr.


@ScottD Yes, I agree with you that GL.iNET has some work to do but I’m sure they with get it done along with the ability to enable the built in GPS on the X3000 via a user switch and ability for it to communicate on TCP or UDP and option to customize the port #. Many other router manufactures have this ability already as well.

I did have to switch back to the “ROW_Generic_3GPP_PTCRB_GCF” profile as the “ROW_Commercial” profile quit working. I was also able to connect to the 5G SA network as well the second time I tried it. I may have to do a little more playing around with it all but It looks like its working better now.