Tailscale Exit Node Not Working

To clarify, I am NOT trying to use my router itself as the exit node. I am trying to use it so downstream devices use the exit node as their IP.

I posted a reply in this thread: The interface is connected, but the Internet can't be accessed - #30 by alzhao
Judging by the comments, it looks like this “internet can’t be accessed” message is related to Tailscale somehow. Here is the comment with all of my details:

All, I am getting a very similar error. I am also a Tailscale user. I was able to use my GL Beryl MT3000 flawlessly for months as a subnet router pointed to an exit node for months with no issue at all. I have done all of the standard Tailscale setup, etc. As I said it was working for months.

I recently moved and it stopped working. I had made no other changes to the router at all before it stopped working. Then I ran into an issue where using the Tailscale exit node bricked my internet. As soon as I turned this off it worked again. Though I never had to so this initially, I setup a firewall zone and interface like is mentioned here: Help to configure tailscale as a proxy service - Installing and Using OpenWrt - OpenWrt Forum
This fixed the issue of the Tailscale exit node completely killing my internet, but it makes no change to the external IP when I check whatismyip. I disabled mwan3, but that did nothing.
Now I am currently getting the “The interface is connected, but the Internet can’t be accessed.” error similar to what a lot of others here are getting, and similar to them my internet works fine without issue despite this error. It displays whether Tailscale is on or off. I ran the commands that were supplied above in this thread and this did not fix the issue. I’ve tried several different firmware versions,but am currently on 4.2.3 because that seemed like it was the most stable.
The only thing that I changed that caused this not to work was moving and connecting to a new modem. As you mentioned above, is that possibly what the issue is? You mentioned changing the WAN IP, but I can’t do this as it is not my Modem. Do I need to change the subnet route of the GLiNet and/or change the LAN IP from the default 192.168.8.1?

Any help would be greatly appreciated.

Update:
I manually installed version 4.4.5 and this fixed the no internet connection error message, but doesn’t fix any of my Tailscale issues.

Better if you can attach a screenshot of the Internet menu.
And please set the manual DNS server to 8.8.8.8 to take a try.

Which internet menu you are you wanting me to show? I tried the manual 8.8.8.8 DNS as you said and this didn’t have any effect on it changing the IP address as I need it to, it still shows my real IP. Also, here is a screenshot from the Tailscale page. It does a thing where it will show as connected then it’ll say connecting again then it’ll reconnect. Not sure what the issue is there that would be causing that either.

Is there anything else that I can check to try to get this working? I really need to get this working for my work.

Here, Internet status page. Can you post screenshot

Here is a screenshot of the internet page, do you think it’s a DNS conflict? Also thank you for taking a look.

It seems that you cannot start up the Tailscale service, have you work this router as the exit node as per the post you provided?
If so, maybe you can give this router a factory reset. Since you shall use other site as the exit node but not this router to show other Internet IP address on this router.

I have factory reset this router more than three times and it has not solved the issue or made any difference at all. Also, I can start Tailscale, but the issue is that it won’t change my IP to the IP of the exit node which is what I want. Tailscale will connect and show as active in my machines, but it will give me that connecting every 30 seconds or so like in that picture, like it is constantly disconnecting and reconnecting. I also have no use for using this device itself as an exit node.

Is there anything else that I can try to get this to work?

Shall we arrange a remote access for this issue?
I have sent you a email to request it, you can just reply that email to make it.
Thank you.

Did you see my latest email? I am ready to start a session as soon as you are ready for it.

Update for this case, so that other guys can find a fix if the same issue.

Thanks to the kindly help of @chen1, we have found that this issue may be related to the wan/lan route rules of tailscable, and we now have fixed it in this beta firmware v4.4.6. You can download it in this link:
https://dl.gl-inet.com/?model=mt3000&type=beta

I can confirm that this corrected my issue. I would like to give a big thanks to the Gl.iNet staff here, they were very helpful and fixed it for me.

1 Like

Hi @rain , this beta release is inapplicable for Beryl AX. do you have a recommendation to make this change manually by sshing into the router.

Sure, you can also work it with these commands:

sed -i 's/route_param="$target dev $dev"/route_param="$target table main"/g' /usr/bin/gl_tailscale 
sed -i 's/\/sbin\/ip route add table local $route_param/\/sbin\/ip rule add to  $route_param/g' /usr/bin/gl_tailscale
sed -i 's/\/sbin\/ip route del table local $line/\/sbin\/ip rule del to $line/g' /usr/bin/gl_tailscale

Hm, these changes did not seem to make a difference in my case.

Maybe you just come across another different issue, could you kindly describe it?

This sounds a lot like my issue. I am on a brand new GL-A1300 with firmware 4.5.0. What info can I provide to help troubleshoot this?