Tailscale Security Vulnerablity

I am using Tailcale on my Flint 2. Today, when I logged into the Tailscale Admin Console, I saw a red arrow by instance of Tailscale installed on the Flint 2. When I hovered over the arrow the following message popped up

This machine is running a version with a known security vulnerability. It’s recommended to update to 1.58.0.
Follow these instructions to update this machine.

The version running on Flint 2 is 1.32.2-dev-t.

Do you know the nature of this security vulnerability? Also, is there a way to update to a newer version?

I believe this should answer your questions:

Besides that, I believe the tailscale forum is of more help:

@aaylnx If you don’t mind testing, feel free!


Seems to be working just fine. Good job. Thanks.

1 Like

Thanks for the feedback, glad it worked!

1 Like

I updated the Tailscale packages through the GL.iNET and it worked! BUT… there is a bug, sometimes when I turn off the Tailscale function on the GL.iNET Web UI, it doesn’t actually turn off and the router keeps connected to Tailscale, and if you turn it off and reboot the router it connects again to Tailscale (having the toggle turned off). I had to turn it off using SSH and it seems to be okay now, now it keeps turned of if I reboot the router

How did you turn it off using SSH?

Entering the command: tailscale down and then to see if it’s down: tailscale status
You can enable it with: tailscale up
If you just enter tailscale it will show you the list with all the commands.
Keep in mind this happened after I updated the Tailscale packages, when it had the old package it was working fine when I turn it off, but of course an old version with a vulnerability, now I’ll try to test if the Beryl AX works as exit node, so all the traffic goes encrypted to my house like a normal VPN server/client, I’ll need to use SSH as well because on the GL.iNET Web UI it doesn’t work

You can’t turn it on/off using the UI?

When I turn on the exit node option on the GL.iNET web I can’t select the destination IP for the node, so it’s not working if I hit apply, but it’s possible using SSH, I will try as soon as I can, it might be because I updated Tailscale :thinking:I tested on my PC yesterday and it worked as an exit node, the router needs to be set as exit node so that way the option for exit node can be manually enabled on Tailscale

Thanks for the script. It works, but I needed to reboot before it registered the updated version.

In addition to my last post, when I accepted a router update yesterday, tailscale was reset to the previous version. It’s not a real problem since I can just download and reinstall, but hopefully they get an updated version soon.

1 Like

I was mistaken. For some reason this script is not updating things for me. If I download the tailscale and tailscaled binaries manually and replace the old ones with the new ones, that works.

What router do you use?