Tether issue with IOS 14.7.1 and GL-MV100W

Hi all,

I have troubles connecting my iphone 12 IOS 14.7.1 to the GL-MV100W in tethering mode.
I just returned the GL-AR300M to the shop to get a GL-MV100W but I run into the exact same issue as with the AR300M:

  • I connect the router through the usb cable
  • I trust the ‘computer’ on the iphone
  • the iphone shows the blue Personal Hotspot connected sign in the upper left corner.
  • When i click the connect button in the router interface the connection fails with an error.

Any suggestions?

Router running on firmware:
2021-07-01 18:12:44

After you click the connect button, can you toggle the hotspot on your phone off, wait 5 seconds then turn it one again?

Hi Alzhao,

Thanks for you reply. I tried your suggestion but without succes. The iphone shows the blue connected sign as soon as I toggle the hotspot on. But the router is not picking up the connection.

Any other suggestions?


Seems we relied you via email. Hope my colleague can help you out.