Tethering iPhone works but no Internet


I’ve just bought the 300n-V2 Router to tether to a phone, my issue is that I have managed to add a wireless repeater but it only works with my phone. I have several iphones and wanted to use a spare one. No other phone will connect via the wireless repeater.

My phone scans and connects, works and provides a internet connection. All the other phones I tried (All iPhones) scan OK but will never connect.

I tried to tether and that didn’t work on any of the phones. I upgraded the firmware on the V2 and also on one iphone (7) to 14.3 and then I could get it to tether but it offers no internet connection.

I also tried another iphone (A 6 Plus on 12.5) and that tethers but offers no connection. I cannot set either of these up as wireless repeaters either.

When I tether a couple of times its offered a connection for maybe 30 seconds / 1 minute and then it stops.

I have also changed the DNS settings etc

Can someone plese help, I’ve been through all these posts and I’m getting no where. I’ve followed all the advice and nothing seems to work.

Are you tethering your phone via USB or wifi?

A little bit confused.