Tethering stopped

Hi,

I just got a GL.iNet GL-MT300N-V2, one of the reasons why I bought it was because it supported USB tethering. I got the Internet to work via tethering for a minute or so but then the Internet stopped. I looked at my phone and USB tethering has been disabled. I cannot enable USB tethering while connected to GL.iNet GL-MT300N-V2. I can connect the phone to a desktop and laptop and USB Internet via tethering works on them.

Did the phone company (GoMo Republic of Ireland) disable this ? I bought the phone separately. How can I get it to work again?

Phone: Umidigi F1
Should I try Easy tether? https://docs.gl-inet.com/en/3/app/tether/

It’s probably your internet provider does not allow tethering. Tethering is being detected while not permitted and turning off. Yes Easy will probably work…I Just set it up on GL-MT300N-V2.

Follow my instructions here to set it up…

Then to hide tethering you may also have to change the TTL. Very easy. Just to firewall custom rules and paste this command at the bottom. It worked for me. The advantage of Easytether is that is you’re not using the regular USB Tether which may alert your provider. But that’s not it…some provider use TTL check to detect tethering…That’s why you will need this in firewall custom rules.
iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65

1 Like

Hi,

Thanks for the reply. I’m just trying to get those files together now and try your walk through, it seems as though some of the links you provided are invalid, 404. My GL-MT300N-V2 shipped with firmware 3.025 so I’m not sure about an older version.

GL-MT300N-V2 firmware:
Current Version: 3.025
Compile Time: 2019-08-05 10:04:08
Last Update: unavailable

http://www.gl-inet.com/firmware/mt300n-v2/clean/
OK
gl-mt300n-v2-3.0-1011_clean.bin 3841K
lede-gl-mt300n-v2-clean.bin 3841K
lede-mt300n-v2-clean-2.264.bin 4097K

https://www.gl-inet.com/lede/ramips/2.264/packages/base/
-> URL is a 404

https://www.gl-inet.com/lede/ramips/2.264/packages/mt7628/
-> URL is a 404

kmod-tun_4.4.93-1_mipsel_24kc.ipk
http://images.freifunk-rhein-sieg.net/ruppichteroth/packages/gluon-su-rr-stable-2.9.12/ramips/mt7621/

zlib_1.2.11-1_mipsel_24kc.ipk
http://openwrt.jaru.eu.org/lede/17.01-SNAPSHOT/packages/mipsel_24kc/base/

libopenssl_1.0.2k-1_mipsel_24kc.ipk
http://downloads.libremesh.org/dayboot_rely/17.06/packages/mipsel_24kc/base/

easytether-usb-openssl_0.8.7-1_mipsel_24kc.ipk
http://priceisright.us/GL/

kmod-mii_4.4.93-1_mipsel_24kc.ipk
??

kmod-usb-net_4.4.93-1_mipsel_24kc.ipk
??

kmod-usb-net-cdc-ether_4.4.93-1_mipsel_24kc.ipk
??

kmod-usb-net-rndis_4.4.93-1_mipsel_24kc.ipk
??

Opkg Package Manager
https://openwrt.org/docs/guide-user/additional-software/opkg

aindriu…I did NOT use those instructions you’re trying to follow. While searching to set up Easytether on my newly bought MT300V2…I stumbled on those instructions. I came to find out those broken links… I posted my way of doing it…which is plain simple so that people would do the same. It seems you did not read my post there…I gave the link to the original GLI.Net instructions…they are very simple. The only issue was to locate the right driver and that’s why I pointed people to the driver I’m using…
Don’t follow the instruction from the other poster…I mentioned I followed the original instructions…thru this link…here…https://docs.gl-inet.com/en/2/app/tether/

They worked on mine purchased a week ago. To find the driver check this folder
\easytether-usb-openssl_0.8.9-4_lede-17.01.6\17.01.6\ramips\mt7628 file name: easytether-usb-openssl_0.8.9-4_mipsel_24kc.ipk
If you still have trouble let me know and I will post a guide in this thread to make it easier for you
Don’t forget to do the TTL change. Easytether allows you only to not use the native USB Tether since it may be checking your plan. But if your provider use TTL in addition to taht…you will need to make the TTL change. which is very simple. Just go to advanced setting which will bring the full Openwrt Luci interface and in firewall …custom rules…paste the line (iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65) at the end without parenthesis.

1 Like

Befor you do all the above…please check your cable again… USB Tethering will turn off also if it’s not detecting a usb host. meaning if somehow the cable or the MT300V2 is off, usb tethering can’t be turned on. I’m surprised you can tether fine on computer…that’s why I think the cable or the MT300V2 is at fault.

Hi nashi2000,
Thank you very much for the follow up. I spent some time there getting to know the different files, In the end I had just the one file to copy over and some commands to run. You helped a lot! I got EasyTether to work straightaway.

With the limit on HTTPS I was looking for sites to check, I got a few HTTP and the Internet connection was really fast, however the behavior is a bit odd, on the phone it says Connection established, then after a few minutes it goes off, once I pick the phone up again I get an Internet connection but it doesn’t seem to be the phone, the instructions seems to be coming from the mini router.

I have to see how things work with it but thanks for the help with it!!

Great. again do the TLL rule in case your provider snife the TTl to block internet.
I’ve used the same for bigger rooter. Wester Digtal mynet 750. An old router where I flashed the Rooter firmware which openwrt with a better UI. And it worked.

I bought the Pro version of EasyTether and strangely it didn’t seem to work as well the Free version. I got the connection established message but no traffic. I installed EasyTether on my desktop and I got faster speeds than regular USB tethering.
My phone company got back to me this morning and they said they don’t restrict any USB tethering and it has to be my device that’s the problem. I tried another USB type C cable today and got the same results. My only conclusion is that the problem has to do with the GL-MT300N-V2. I will run the TTL change again.

I got it working, it was my USB type C cables, I tried a new cable that came from a new 10.5" Tablet and it was like plug and play, tethering worked perfectly. Third time lucky.

1 Like