I have a new router. When I connect my iPhone, and go to Settings in web page, and WAN settings, and select “Tethering” tab. But I cannot see my iPhone. iPhone is connected, and “hot spot” feature enabled. What is the problem?

I will test iPhone.
Android should have no problem.

Thank you. I will look forward to hearing of your findings.

Are there any results to report? Any recommendations to recognize iPhone for tethering?

hi, I justed tested.

There is a kernel module kmod-usb-net-ipheth which is for iPhone tethering. This is module is not installed in the stock firmware. I install and retested again and it doesn’t work. This module should work with older IOS version but not on IOS8. Maybe Apple don’t encourage this and disabled something.

I don’t know if others have a solution.

This kmod-usb-net-ipheth kernel module is compiled from http://www.libimobiledevice.org/ , here is a old openwrt ticket: #10157 (iPhone USB Tethering support) – OpenWrt

libimobiledevice.org claims their code is now working with IOS9 now. So need to check the code and recompile.

do you mind I get some test next week?

Next week is good. Thank you for your reply.

For iPhone tethering, here is a solution. I tried and it works with iPhone 6, IOS8


I am using GL-AR150 OpenWrt CC, need to install the following modules:
kmod-usb-net-ipheth libusbmuxd libimobiledevice usbmuxd

Need to execute usbmuxd manually in order to see the iPhone devices.

I got a timeout when connected to iPhone, but when re-plug in iPhone and it works.

The iPhone devices is identified as eth2 and you will be find it in the webUI.

Need to write the hotplug scripts so that the usbmuxd is executed automatically.

The thread at openwrt is interesting. I am trading my 6416 for a 150. I hope the issues are cleared up soon, and I will try this at my first opportunity (maybe 3-4 weeks).

Have you made any progress on the hotscripts?

Not yet. I need to borrow the iPhone from my wife!!!

I installed the packages on my old iPhone 4. I then added the line


to the Local Startup per the OpenWRT forum posts.

I rebooted the router, enabled the hotspot on the phone and connected it. there was no ETH2. I disconnected and reconnected it and then could find ETH2 under Wan Settings=> Tethering. Entered submit and the phone connected… for about 30 seconds. The hot spot on the phone keeps cutting in and out and I keep getting asked if I “trust” the device.

Not clear on how to debug the situation.

I know the hotspot works reliably when I connect the PC to the phone hot spot via wireless. I’m also not sure why I would want to tether the phone via a cable when it’s easier to use the hotspot and connect to it via wifi.

I don’t know why people want to tether iPhone too. But we always think in our own way, other people may just think differently.

Some reasons I can think of for all smartphones:

  1. If you share the hotspot of your phone, you need to tell people the ssid and password, but if you share your internet to one exiting router, people may not aware it. I have done this in my office using my android phone.
  2. Smartphone's hotspot is not efficient when connecting more users, because the phone's wifi chip is not for that purpose.
  3. Smartphone's hotspot may shutdown if there is no activity for some minutes.
  4. Smartphone's hotspot drains your battery. But by using cable, it can charge the battery at the same time.


Thanks Alzhao, some good answers, especially 1 and 4.

I would like to have this option, but have the “cycling” issue noted above. Any ideas on how we can debug this.

Glimpse, are you out there?? What IOS and phone do you have?

Hope I can have time to debug it.

you can take a look here sounds interesting

Great, thanks!