The interface is connected, but the Internet can't be accessed

If it is the configuration then why has it never happened on firmware versions 4.1.0 beta 3 and the ones before and only started after (as others have also pointed out here) with the exact same configurations???

I don’t see who has the exact issue as yours.

The link given in this thread referring to a bridge issue due to uboot.

Same issue here. I can browse the internet but many of my applications stopped working, saying ports were not correct…please solve this asap and give a solution.

Can you show the details of the Internet status? What is the upstream network?

The message may display it correctly, means that it does not have Internet.

Same.



No active VPN or some custom settings.
I have access to the Internet. Well, I’m writing this message with this error now.

It was before the 4.4.5 firmware version. To be clear I wasn’t able to use auto update because on the update page, it also was saying that I don’t have an internet connection. So I did a manual update.
Now it also shows an error that I don’t have a connection.

One noticeable thing is that I can’t open Transmission web GUI but I can open Network storage. Odd situation.

one more. From luci, on the software page, I selected Update list and got

I found out what was wrong with Transmission.
Update to 4.4.5 deleted transmission packages. It is fine I guess as I have all settings and torrents on the attached storage so no need to configure everything again.

And about this error. Reboot didn’t remove it. But after I removed the WAN cable and connected it back this error vanished. Will see if it comes back with time.

1 Like

Oh yeah. I use Tailscale. Maybe it is related.

hi, rossfilipchuk
This maybe due to conflict between your wan ip tailscale subnet.Can you change the wan ip or turn off tailscale and see if it works. Thanks!

This issue is not constant. From my last post, I didn’t see this issue and I didn’t change anything. Tailscale is enabled all the time.

Maybe this error message appears sometimes but I probably missed it because it doesn’t interrupt my connection. I still can load sites and I don’t spend a lot of time in the admin panel.

It’s back. Looks like it is certainly related to Tailscale.
Current issue status
on Macbook I can use Internet access with no issues. It just works. Tailscale client is not enabled. But I see the same errors in the Admin panel.

On Windows PC I don’t have access to the Internet. It is what I see in the Admin panel


Interestingly, I can connect to Tailscale from a Windows PC. When Tailscale is connected I have Internet access. I can’t explain why. And I can’t access the router admin panel when Tailscale is connected.
192.168.8.1 nor Tailsclae’s IP work.

Sometimes, in the admin panel, I can see the error message “No WAN cable detected” or something like that.

Only manually removing the cable from the router removes this error state.

Could you please ssh login this router, then try with these commands?

sed -i 's/route_param="$target dev $dev"/route_param="$target table main"/g' /usr/bin/gl_tailscale 
sed -i 's/\/sbin\/ip route add table local $route_param/\/sbin\/ip rule add from $route_param/g' /usr/bin/gl_tailscale
sed -i 's/\/sbin\/ip route del table local $line/\/sbin\/ip rule del from $line/g' /usr/bin/gl_tailscale

Should I try to run these commands when this issue is active or it doesn’t matter?
Now this issue is gone after I removed the WAN cable.
Should I wait until it comes back?

Am I doing it wrong?

seems this symbol ( ’ ) is wrong

Fixed the code format. Pls try again.

Now commands work.
What should I do next? Just wait for the error again? Should this error be gone?

This is what we are expecting you to check.

Pls let us know if this happens again.

All, I am getting a very similar error. I am also a Tailscale user. I was able to use my GL Beryl MT3000 flawlessly for months as a subnet router pointed to an exit node for months with no issue at all. I have done all of the standard Tailscale setup, etc. As I said it was working for months.

I recently moved and it stopped working. I had made no other changes to the router at all before it stopped working. Then I ran into an issue where using the Tailscale exit node bricked my internet. As soon as I turned this off it worked again. Though I never had to so this initially, I setup a firewall zone and interface like is mentioned here: Help to configure tailscale as a proxy service - Installing and Using OpenWrt - OpenWrt Forum
This fixed the issue of the Tailscale exit node completely killing my internet, but it makes no change to the external IP when I check whatismyip. I disabled mwan3, but that did nothing.
Now I am currently getting the “The interface is connected, but the Internet can’t be accessed.” error similar to what a lot of others here are getting, and similar to them my internet works fine without issue despite this error. It displays whether Tailscale is on or off. I ran the commands that were supplied above in this thread and this did not fix the issue. I’ve tried several different firmware versions,but am currently on 4.2.3 because that seemed like it was the most stable.
The only thing that I changed that caused this not to work was moving and connecting to a new modem. As you mentioned above, is that possibly what the issue is? You mentioned changing the WAN IP, but I can’t do this as it is not my Modem. Do I need to change the subnet route of the GLiNet and/or change the LAN IP from the default 192.168.8.1?

Any help would be greatly appreciated.

Update:
I manually installed version 4.4.5 and this fixed the no internet connection error message, but doesn’t fix any of my Tailscale issues.