The mifi does not turn on


The mifi does not turn on and neither the leds turn on when it is loading (only the first led) but after being almost 12h it is still not turning on so it should be charged already.

What can I do to fix it?


Hi can you show us in a picture.It’s hard to focus on the problem by your feedback

Hi <span style=“background-color: #f9f9f9; color: #222222; font-family: source_sans_proregular, ‘Helvetica Neue’, Arial, Helvetica, Geneva, sans-serif; font-weight: bold;”>z353664407</span>

Send attached file with mifi photo.

Hi <span style=“background-color: #f9f9f9; color: #222222; font-family: source_sans_proregular, ‘Helvetica Neue’, Arial, Helvetica, Geneva, sans-serif; font-weight: bold;”>z353664407</span>

I send the file with the photo attached

Hi Axel José,Press power KEY for THREE seconds the Mifi will power on.

you can press it when it’s charging,the function is also work.please make sure you press the key for three more seconds.

and press the key for a monment is to display the power lever.

when you charge the MIFI,how many LEDS are flashing?

thanks for your reply.


If it isn’t charging there is no led on.

If it is charging, only the first level of power is on.

When I charge the mifi, only the led that is in the picture is on, even if it is 15 hours charging.



You may want to test that the power supply is or is not a problem.

I can run mine from a USB connector on my desktop.

I also experienced a bad cable one time, but that is rare.

If the unit is NOT connected to the power and you momentarily press the power button do you see any LEDs?

Hi RangerZ:

I do not understand how to connect the wifi to my desktop computer.

I used different cables to charge the battery

The mifi does not switch on any Led if it is not connected to the electricity.


To charge the mifi you most likely have a usb to usb micro cable, which is the same as you may have for an android phone. You connect this to a small power brick that goes in the wall. You may or may not have got these with the MIFI.

The end of the USB cable that goes in the power brick can connect to a PC, battery or other USB devices. You can connect this to a PC where you would connect a thumb drive (Data drive)

With the MIFI not connected to anything, press the on/off button for about 1 second or less. How many LEDS do you see?

@Axel José, I believe that the mifi may has a problem. Maybe you can exchange it.

Have you contacted

The battery has heated and inflated.
I realised this because I had wifi but no more internet via modem.
I connect and no longer see the modem as if it were no longer physically present.
I unplug it, turn it off, take out the battery,
wait for it to cool down before turning it on again.

I plug it in, but it won’t start.
The first LED flashes and the USB power supply sizzles to the rhythm of the LED.
I try with other power supplies and USB cables, always the same.

What can I do?

If you take out the battery, mifi should still works.

Do you mean the battery capacity LED or power LED is on?

The first batter capacity LED should flashes and the Power LED should be solid.

I have the power led flashing and in the dark I can also see the wifi led flashing at the same rhythm.

In the dard it may be only power LED’s light goes to wifi led.

Seems your device does not boot anymore. Can you give you a photo? Seems you mean the battery indicator, not power LED.

I’m talking about the Power PWR light, not the left-handed lights that indicate the battery charge level.

I see. Can you pls change an more powerful power adapter, e.g. 5V2.1A and above. Without battery, the device use power directly from the power adapter which may not be sufficient.

I have an anker 60w which can deliver 2.4A per port, I also have a car anker which delivers the same thing.

it still doesn’t start

I also tested with a USB meter, it indicates 0.07A when the led lights up.

Seems that it is dead.

Send for warranty. Pls cite this post.