Think I have bricked my flint :(

So i was on here last night as i have been having connection issues with hard wired and wifi devices, decided to upgrade to version 4 beta. I managed to do a UBOOT last night (first time i have tried) and all went well. managed to do it while the rest of the house slept as not to interrupt anyones internet time (great dad).

this morning everything was ok, then this afternoon as i was adding some wireguard protocols it started popping up at the top a warning that it needed a reboot as “something” was wrong with the environment (apologies as i didnt think it was important so I didnt take much notice of what it said) I rebooted as requested, and then could only log in via LUCI.

I decided to reflash as I like the GLI interface for wireguard/vpn…

i used the same img file openwrt-ax1800-4.0.0-0528.img as i did last night but went via LUCI.
left it for about 20 minutes while i pottered about, came to check on it and nothing was connected, left it another 10 minutes (knowing that it only took about 5 last night) and nothing.

now all I get is “unrecognised network” checking ipconfig and the router isnt giving out a gateway address.

when i checked in ipconfig i get randomness like

ipv4 169.254.20.118
subnet 255.255.0.0
default gateway is blank.

is there any way to do a UBOOT via a usb or anything?
im not great with SSH and stuff like that.

be grateful of any help to rescue my friend Flint.

thanks.

can you not simply install the same firmware file again via uboot?

sorry, i was cooking tea while i wrote this, i cannot log back into router as there is no ip address to log into the router with.

trying to put router into uboot, i press and hold reset, flasses 5 times then light dims… but no way to log into router as i cant find it on network.

Have you tried to unplug all utp cables except the one to your laptop or pc so there is only one cable?

Have you also tried to set your ip to 192.168.1.2 static?

Sometimes replugging the power cable can work + 5 second wait pressing reset pin.

For me this worked great within a few attemps.

You router is giving a Automatic Private IP Addressing (APIPA) because it can not find a DHCP server or can’t start.
You might be able to access things from the app using a bluetooth connection
When you go fro 3.x to 4.x the procedure is to use Uboot
When you go from 4.x back to 3.x use LuCi to flash the image.

Try the 4.x using UBoot if that works load LuCi and flash to 3.x

thanks for replies, i wouldnt be able to connect via bluetooth as the app doesnt work on 4.x
i wasnt trying to go from 4 to 3, i was just re installing 4 a second time to start again.

1 Like

The beta version of app support the firmware 4.x.
Note: It may has bugs and unstable.

Beta version:
iOS TestFlight: Join the glinet beta - TestFlight - Apple
Google Play Beta: https://play.google.com/apps/testing/xyz.goodcloud.glinet

Any more suggestions? I can’t see the flint at all in Bluetooth, I wasn’t even aware it has Bluetooth installed, updated to the new beta app and can’t see the flint when turned on normally, (white light) or Uboot, flashed 5 times then goes to a lighter white LED or grey colour.

Little disappointed at this tbh.

Thanks for any more suggestions.

Does SSID for wireless come up? So every body says the now how to use Uboot but here is the guide.

I would read it, people have a tendency to over look stuff like depressing the reset button then powering on the device (ALSO when power on the Flint AX1800 plug power into router then into power outlet) I have messed up the procedure a few times and then go back and follow word for word and thing worked

Also looking back at your initial post you stated that you uploaded the .img file to LuCi, that should have been a .tar file .Img file is for Uboot.

When running normally, you still cannot use the router?

I wasn’t aware of that. First router I’ve had like this. The other I have, if it’s the wrong file type it wouldn’t allow a update to start. I’ll have a look at that guide

Nope. No gateway is given so when connecting via windows machine it just says unidentified network and doesn’t give me a IP address to log into it. No SSID for wireless either.

Maybe a factory reset but I don’t now for sure. When I do the UBoot I always use a wired connection into the WAN and set manually the IP to the instructions 192.168.2.1. Can you get into UBoot? what Version? Uboot may need to be updated

Try to get into Uboot before factory reset( this could corrupt things further From what I understand you have triggered one of the safeguards for openWRT and it wants you load the working .img file.

I normally connect to LAN1 and set computer to ip address 192.168.1.166 for recovery via Uboot.

If push comes shove you could always solder to the TTL pads.

You only need the first 3 after the LED don’t connect the 4th one as thats voltage