Time period for WPA3. Better WPA3 beta, than 14 years old and broken PWA2

Hi,

quick test.

  • old Android 9 Sony phone : connect correctly in wpa2 psk (5GHz)
  • linux notebook : connect correctly in wpa3 (5GHz also)

No access yet to luci web interface?
No option in gl menu and it is redirected when trying http://192.168.8.1/cgi-bin/luci/

Thanks!

The redirection may be just a browser issue?

I don’t think.
I tried to force refresh and even tried the url directly in “incognito mode”.

I believe ar750s uses ath10 wireless
does this support 802.11w Management Frame Protection ?

Can you just type http://192.168.8.1/#
Add # at the end

A friend has been using the firmware on two AR750S for a few days. He’s been up and running so far. He probably uses a WLAN for non WPA3 devices and a WLAN for WPA3 only devices. It looks like this avoids possible problems with not fully wpa3 compliant client devices.

Its looks like, WPA3 is supported on this time by:

I have not tested the new WPA3 firmware because I only have smaler ar750 and ar300.

1 Like

That’s simply the url to get the gl-inet web management interface.

I’m asking about the openWRT one !

There’s a redirection on the usual openwrt url (and anything else in fact):
http://192.168.8.1/cgi-bin/luci/ -> http://192.168.8.1/#

curl http://192.168.8.1/cgi-bin/luci/
<html>

<head>
    <meta http-equiv='refresh' content='1; url=/#' />
</head>

<body>
</body>

I do extroot on my 750. have 19.07.2 clean loaded and use wpa3 no problem. also have freeradius3 and testing with wpa3_peap loaded. :wink:

1 Like

I have tested wpa2/wpa3 mixed mode sae and eap (enterprise) and have seen wpa2 working and wpa3 clients stepping down to wpa2 making it useless. What I have also read is to never have two ap’s on the same radio with different security schemes which I tested and found it not to be necessary but actually worked fine. please don’t take my word for it but please test yourself incase my testing was in correct cause i really diddn’t believe it myself. maybe a new enhancement in 19.07.x? Note no mixing enterpise because that defaulted to enterprise

I’m trying to use IPv6 with this ar750s-3.200 firmware. I can’t seem to get any IPv6 addresses on my client machines on the LAN.

I have run this first to enable IPv6:

uci set glipv6.globals.enabled=1 && uci commit

But I can’t get IPv6 addresses to show up on my LAN. Does anyone have a working set of /etc/config/network, /etc/config/dhcp, and /etc/config/firewall to let this work?

(Not currently using a VPN, so not worried about information leakage.)

If you do not mind I ask, did you reboot the router after you do that?

Pls also show /etc/config/network

I ended up getting it working by just putting this behind another router and setting it to be a dumb AP. (no firewall, bridged WAN, LAN, & Wifi).

WPA3 is working just fine though. I’ve noticed that other people are having issues with IPv6 and some routers with 19.07.x I wonder if that is an issue here?

(And yes, I did reboot the router.)

Open WRTR 19.07.3/ now available:

“Upgrading to OpenWrt 19.07.3
Upgrading from previous OpenWrt 19.07 versions is straightforward thanks to the sysupgrade utility: sysupgrade from web interface or sysupgrade from command-line.”
Source: https://openwrt.org/releases/19.07/notes-19.07.3

It may be that some of the a little more security conscious users are ready for a test of a more secure gl firmware…

Apple is supporting WPA3 since iOS Version 13

There are still issues to be resolved with WPA2/WPA3 interoperability…

It’s mostly on older devices that do support WPA2, but the new epigrams can/will cause issues here on the client side…

One other vendor of WiFi4 and WiFi5 router, which use open wrt 19.07.x firmware and support mixed mode forWPA2/3 Personal, reporting its need by some clients to reconnect once (setup the connection to the client new by typing the password). I have the same experience with WiFi5 router which supporting mixed WPA2/3 to WiFi6 client devices. No problems, after first new logon by typing wifi password.

Don’t confuse Wife 4/5/6 with WPA2/3 please…

Patches applied on AR150 on openwrt master, which is WiFi4, can support WPA3

sfx

I dont confuse this. I’ve changed the wording a little bit to make it more clear.

Great news. The stable of OpenWrt 19.07.4 are out now:

On openwrt.org are already available the 19.07.4 at minimum for p.e. follow mainstream router:

How about a release by gl ?

If I dont have seen wrong by one other vendor, on of minimum of his routers, offer now by same hardware a higher wifi channel bandwide and wifi speed. (changed from 20 to 40 MHz or from 40 too 80 MHz or like this by same Hardware)

For checking actual openwrt for other gl router, you can check on follow page: