Timezone sync issue on GL-SFT1200

Woke up this morning to my OpenVPN stuck in a TLS Handshake failure loop and looking into the issue I found that the time and date on the router is somehow wildly out of sync.

The sync button does nothing, I have tried to restart, update firmware, revert firmware etc. and gotten nowhere.

Taking a deeper dive I tried to see if I could change the time and date via LuCI but it’s not installed and asks me to update plug-ins before installing which doesn’t do anything.

I’ve tried to manually update and install LuCI using SSH but I get the following errors:

Collected errors:

I can access the files via my browser on laptop and mobile so not an issue with my ISP.

Trying to use wget gives me an SSL certificate error which I imagine is because the date and time are wrong.

So in conclusion:

  1. Can’t use VPN because date and time are wrong
  2. Can’t change time without LuCI
  3. Can’t install LuCI without updating packages
  4. Can’t update packages due to SSL cert error
  5. Can’t fix SSL cert because date and time are wrong.

I’ve been banging my head against this brick wall for hours now so any advise would be appreciated.

I’d disable the VPN for the moment. Try opkg update before attempting opkg install $packageName.

More to your over-reaching issue: NTP server definitions are located in /etc/config/system. So is the time zone (zonename). Add some static IPs as a failsafe:

config timeserver 'ntp'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'
        list server '' # 0.openwrt.pool.ntp.org
        list server ''   # 1.openwrt.pool.ntp.org
        list server ''  # 2.openwrt.pool.ntp.org
        list server ''   # 3.openwrt.pool.ntp.org

/etc/init.d/sysntpd stop && /etc/init.d/sysntpd start && date &/or reboot should do it.

ps/ OpenVPN? Really? WireGuard, man… wireguard.

You are a hero my friend!

The time and date synced straight away after adding the static IP Address.

Thanks for the help!

ps/ I’ve got both :slight_smile:


Shhhh! You don’t need to say the quiet part so loud.

More seriously though, feel free to mark the ‘solution’ to let others know when searching in this forum. Have a good one.