Tips for using free VPN/Wireguard

Hallo, just bought the Mango router. I will only use the router a couple of times during the year in a hotel/public wifi. For that purpose it’s not really worth to fall back on a paid VPN provider. I tried it out extensively with ProtonVPN and vpngate configuration files. Not a single file worked and I could not establish a VPN connection at all with those configuration files. A fallback solution would be to get another Mango router and establish a openVPN/Wireguard server at home and have the second Mango connected to the public wifi that then acts as client connecting to the other (my current router, Fritzbox, only supports ipsec and does not support OpenVPN), right? Any idea what could be wrong(ly done) with the free VPN providers? Are there any other ideas for not generating lots of costs and without a subscription (there are no free cloud servers for a VM to set up one’s own VPN, right, except the one-year free AWS tier)? Thanks

A few comments. Using a Mango at home should work. I am using a GL Inet Microuter-N300 as my home Wireguard server, plugging it into my home router, and using port forwarding. For Wireguard clients, I and using a mixture of Gl Inet routers and other systems with Wireguard installed to attach to my N300. The N300 is not real fast as a Wireguard server, but most of the remotes sites I’m at don’t have real fast internet anyways. As for cloud systems, Oracle will give you two micro cloud systems running Linux for free, supposedly forever, and they come with lots of free Internet bandwidth. There are multiple “How To” documents on-line on how to put Wireguard and OpenVPN on an Oracle cloud server. Just google it.


i’m also using two mango router. One is placed in my home-network (WAN-port is connected to my network, port open in mango for 80 and 22) and portforwarding is configured in Fritzbox for wireguard port. 2nd mango router is configured as wireguard client for hotel / holiday usage. When i turn the hardware-switch, i set it that wireguard client will be enabled and disabled. Once wg-client is enabled, all internet-traffic will be routed to home network.
I’m also using wireguard client on iphone. Really interesting, because VPN is not stopped. Roaming is working either in WLAN and go to LTE. I’m also using fritz!fon-app over wireguard, working perfect.
Ja, Fritzbox only support ipsec, nothing else.
Wireguard is configured quite easy. Don’t know why wireguard vpn providers are not working. By the way, i don’t know why people use vpn provider. It’s not more secure because the provider itself can check the traffic.


Thanks guys for the tips. And also nice tip with Oracle. Did not come across that. Nice offering but they will not get my credit card details which is a prerequisite for registration. Hence, no option. Would have been an interesting thing to build up something on one’s own and for the casual use of the VPN. I then fell back on my original idea (as also mentioned by you as a worthwhile thing) and went for a second Mango router.
These are the concrete steps done (Mango1 = server, Mango2 = client):

  • Mango1: set up as repeater, connected to my home wifi
  • main router (Fritzbox): set up port forwarding for device Mango1
    • Ipv4 and mac address get assigned automatically (no edits done for ipv6)
    • Used UDP
    • Set external port for IPv4: 51820
    • Left external port for IPv6 blank
    • Activated the port forwarding
  • Mango1, Wireguard-Server section: started new Wireguard service (local IP address:, local port: 51820), added new Wireguard client, copied the configuration
  • Mango2, Wireguard-Client section: added new Wirguard profile, inserted the configuration

Worked :smiley: Now, just another question to the experts. That’s it, right? That makes the connection all safe when being connected to a public Wifi through Mango2 or are there any further things recommended to be done? Activate kill switch, yes. What about e.g. Dyndns?
PS: I still find it strange that not a single OpenVPN connection with free providers (ProtonVPN, VPNGate) worked on my end. After all, these two are mentioned in the documentation to work. Will not need them but I’d just be curious if anyone else made the same experience.