Tor before vpn

Hello these are the settings I am using. TOR ON, VPN kill switch ON and policies ON Use TOR for all processes on router, use tor on guest network. On the latest firmware.

If I connect a device to the router and set OpenVPN on the device what port should I use?

Do I need to change any settings in the router for it to route over TOR?
(Router-- TOR-- Device with VPN)? Please give details I’m not an expert of exactly what to change in settings.

The VPN should only see the TOR exit node. I understand the risk’s how can I set this up correctly :kissing_smiling_eyes: :worried:

You use Tor on the router and vpn on your pc, not sure why you do this.

The best set up:

Use VPN on the router
Use Tor Browser on your PC

So Tor knows you are from VPN but not your own IP. VPN don’t know where you goes.

Thanks for your suggestion. I want to use the setup as I wrote above I mentioned I understand the risks how can I set this up. Please the VPN is bypassing the TOR policies on the router. Read my post above again for any details of how I would like to set up.

Thank you teams .

  • If i use wireguard on the device (wireguard only uses UDP ) will it route over the Tor network at router level. Or do I have to use OpenVPN with TCP

Please add details on how I adjust the settings to make the device route the VPN traffic over TOR Thanks Alzhao

If you want to achieve your task, you can just set up tor on the router and vpn on your pc.

It doesn’t matter if the vpn is tcp or udp. Both should work.

I don’t think that is right.
How can I check that after the VPN tor is being used and not the direct internet?

The VPN is skipping the TOR connection. When I check PING is fastest to servers near my actual location when the best ping should be closest to the TOR exit node. Showing that is skipping TOR

Tor works on TCP so how is it routing the UDP traffic.

check reply please. I understand they should work but I need to make sure

When I connect to the VPN on PC and click the fastest server is in my real location. When the tor exit node is far. The VPN is passing the TOR firewall and policies it works good alone but VPN is bypassing how can I fix this

Can you try set up custom dns on the router? Not sure if this matters.

Can I get real help with this problem. What should I change with the DNS settings?

The TOR router works right if I connect a device. But if i add a VPN to the same device for example A phone the VPN is bypassing TOR connection on router. The VPN can See the IP address from before the TOR connection my real IP. I want the VPN to connect after TOR

Just change the custom DNS to and

1 Like


thanks for reply. Can you please explain why you say to use googles DNS servers? On the routers GUI using TOR on router

I really don’t understand. Please explain further.

Note. Explain also if I could set any DNS on tor router DNS settings. Any DNS? Maybe the VPN DNS but why do you say googles DNS. Thank you

I just replied below

Any reply? What is the reason for that change for this use case thank you.

Pls omit the dns setting. Tor should auto router the dns to the exit node.

I don’t know your vpn software. I check using speedtest and dnsleak test and all traffic goes via the Tor Exit node, even the dns. Speedtest automatically select the server closer to the exit node as well.

Both TCP and UDP traffic goes via Tor. I don’t have an idea why not.

You can also check your vpn software if it has other method to detect your location. For example using gps if you use on phone.

I still have the same issue.

The tor router works fine without the VPN.

When I connect to a VPN after the TOR connection on another device.

The VPN is bypassing the TOR connection. My VPN offers servers around the world and has an option to pick the fastest server (LATENCY) and to verify that the VPN is bypassing TOR I try a VoIP call, and it works VoIP does not work over tor. What settings can I change in the firewall or rules to make sure the VPN incoming traffic to router is being routed to TOR and not sharing the real DNS which I believe is how the VPN app is getting the information for fastest server (LOCATION SERVICES GPS IS OFF ON DEVICE)


Please I don’t know how to fix this, and I am going to give up.