Torrent Client on GL-AX1800 Flint

How do I set up a Torrent Client on my router GL-AX1800 Flint so I can download direct to an attached hard drive?

You can aria2. It should be able to download Torrent.

I don’t know such an aria2, what is it?

Transmission works :slight_smile:

Transmission works perfectlly for me. However, the aria2 doesnt and I need it to download http/ftp type media. I tried to get tthe webui and aria2ng interface to no avail.

I want to get https working for rpc connections from flexget.

This is what my extra options looks like:

rpc-certificate=/etc/ssl/server.crt
rpc-private-key=/etc/ssl/server.key
rpc-secure=true
ca-certificate=/etc/ssl/certs/ca-certificates.crt

flexget client connects and errors with this:

requests.exceptions.SSLError: HTTPSConnectionPool(host=‘192.168.8.1’, port=6800): Max retries exceeded with url: /jsonrpc (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: self signed certificate (_ssl.c:997)’)))

It doesnt seem xml is compiled in… so im using json.

The aria2 log (debug level) shows this when flexget connects using http (port 6800).

2022-12-10 21:53:21.733562 [DEBUG] [SocketCore.cc:926] Creating TLS session
2022-12-10 21:53:21.733866 [DEBUG] [SocketCore.cc:946] TLS Handshaking
2022-12-10 21:53:21.763138 [INFO] [HttpServerCommand.cc:275] CUID#9 - Error occurred while reading HTTP request
Exception: [SocketCore.cc:1021] errorCode=1 SSL/TLS handshake failure: protocol error

Anyone get this working? I have a GL-AXT1800 BTW.

How and where to write - Basic setup, as
uci set transmission.@transmission[0].enabled=“1”
uci commit transmission
/etc/init.d/transmission restart
I don’t know ше.

Check if you can install the luci-app-transmission package to add the UI under LuCI.

I do not work for and I do not have formal association with GL.iNet.

I have installed all the packages below:
transmission-daemon
transmission-cli
transmission-web
transmission-remote
luci-app-transmission.
But I don’t know how to set the settings.

Did you get the Transmission screen in LuCI:

Yes everything matches

Thanks for the help. I checked the settings according to your screenshots, corrected the paths and it seems to work.

The torrent client does not work again after rebooting the router. I think it’s about setting Config file directory, because the transmission now does not see the downloaded torrents, and when adding a new one, it writes an error, there is no free meta. How to determine the path to the file directory?

there is no free area

Check the size of /tmp mount point on the router by running the df command in SSH. Depending on how much you are downloading, there may not be enough space. If so, you can try plugging in and changing the locations to an USB flash drive.

The /tmp mount point IS 99.97% used, which may be why there is no free area. All data on /tmp will be lost if the router is rebooted because it is likely mapped to main memory.

You can try changing the locations to the USB flash drive, but it is not currently Enabled and may not be mounted for rw (read/write), which can be done by clicking Edit.