Traffic statistics are reversed

I am using a X3000 router
My traffic statistics shown is reversed.
Meaning, the download is shown as upload and vice versa.
I have a lot more download than upload.
How do we fix this?


This is an “issue” with the latest router firmware and I don’t know of a fix. GLiNet will need to issue another firmware to fix this.

1 Like

Maybe @ywp can alert the developers about this?

Is the firmware version 4.4.8?

yup, version 4.4.8 …

Thank you very much!
I will test this problem

I reproduced the bug
We’ll fix it in the next release

1 Like

For now, can you please share, which module under /www/views can i edit to fix this.
This should be very simple

Do you want the front end to temporarily display the opposite data as well? Two wrongs make a right

It is also the same for MT6000 when using Cell Modem via USB. Thanks!

Are you all using 5G?

Yes. My Sled uses RM520N-GL.

gl-sdk4-modem_git-2024.106.25196-10a9cd1-1_aarch64_cortex-a53.tar (366 KB)
I fixed the bug and you can reinstall the ipk for testing
Only available for x3000

Which folder should i copy this file?

Downloaded to root / and uncompressed the tar file. Then ran opkg update and then opkg install filename.ipk. opkg install was successful but didn’t see any change even after a reboot. So then I installed using luci. Again, install was successful but still no change. I’d have to say that it’s still not fixed but it was never super accurate anyway compared to the TMO app. I have no problem waiting for the next update.

ok i will try both ways

You need to extract the content first.
tar xvf gl-sdk4-modem_git-2024.106.25196-10a9cd1-1_aarch64_cortex-a53.tar

It didn’t work, i still see criss-crossed numbers for uplink and downlink

@ywp Could you please take a look? The fix does not seem to work.

  1. First make sure your module firmware is RM520NGLAAR03A03M4G
  2. After decompressing the tar, you can obtain an ipk package and place it in /tmp
  3. opkg --force-reinstall install gl-sdk4-modem_git-2024.106.25196-10a9cd1-1_aarch64_cortex-a53.ipk

I tested it and I have no problem