Tried to Upgrade to Tor FirmWare, Now Brick

Hi, I tried to upgrade to the Tor Firmware using the GL.inet interface.

Now it won’t connect and seems to be a brick.

I dont know how to reinstall it.

I also don’t know how to get into the device to run anything via commandline. I’ve tried ssh, but when I just type ssh, nothing happens

i cannot connect to it

any thoughts on what to do? should i throw it away?

Try flashing the stock firmware via UBoot.

Pls mention router model and which exact firmware you used.

Need to check if the firmware is correct.


I was able to get into to try to reload the firmware

It’s an AR300M.

I tried to install the openwrt-ar300m-nand-tor-2.264.tar firmware previously through the gl.inet interface and this bricked it

Then I was able to get to

I tried to install openwrt-ar300m-nand-tor-2.264.img even though it said to use a higher version number and it didn’t work

then I tried openwrt-ar300m-3.211-1227.img and it didn’t work

after i got the to the screen where it said it was installing both times, I went and did something else and came back in 10 minutes

both times i couldn’t get to even after removing the manual IP4 address that let me get access and doing a restart

I don’t understand the nand or noc stuff and i changed the enabled and disabled the feature by clicking on the buttons for the switch multiple times without knowing what it was doing. I also don’t understand if there are nand versions and noc versions but I remember possibly it saying somewhere in the interface it was n-something and it was not nand and so I think it was the other one.

it’s still bricked. i am not using it for anything crucial at the moment, but would like to get it fixed. I’d like to install the interface that has tor. When I tried to manually install the packages there wasn’t enough internal HD space for all the dependencies and so that’s why I tried to do a firmware update with everything build it.

any suggestions on what to do?

Can you post a screenshot of the uboot interface? At least you should be able to go the uboot interface before we move to next step.

then openwrt-ar300m-3.211-1227.img should be good to flash for the Nand firmware. After you flash it, wait and it should boot up. You should be able to get 192.168.8.x IP.

I have definitely gotten to the uboot interface. I was at and it said Uboot.

I am flashing it in 192.168,1,1 and then I don’t know if it boots up or what it does. It shows a screen saying it’s updated and then says I can close the screen and use it once it reboots. I’ve typically done something else for 10 minutes, come back, closed the browser and then opened it back up to try to access

I changed the manual connection for IP4 to Automatic since I had to use manual to access Uboot. Then when I try to access again it just doesn’t work. I then usually reboot things and it still doesn’t work.

Does it seem like I am doing something wrong?

There is nothing wrong, but the problem is AR300M has two flash. So this may caused confusion.

find the uboot of AR300M here and upgrade the uboot itsefl first. uboot-for-qca95xx/bin at master · gl-inet/uboot-for-qca95xx · GitHub

Enter uboot console and access to do that.

I have one more thing in mind.

As the Tor firmware is old, it may have a problem with hardware which has newer Nand flash.

So better just to use the Nor firmware GL.iNet download center

1 Like