Trying to connect to WireGuard server on GL-B1300, but client log always says "Handshake did not complete after 5 seconds"

Hi, I tried to create a WireGuard server using this tutorial from GL.iNet on YouTube: https://www.youtube.com/watch?v=WPQba8jcZ_o

I believe I’ve followed every step correctly:

  • Starting the WireGuard server using default setting
  • Create new user
  • Scan the QR code from my smartphone using the WireGuard app

When I activate the tunnel on the WireGuard app, I can’t seem to connect to anything. I’ve tried to ping 1.1.1.1 using the Terminal emulator, but nothing. When I looked at the log on WireGuard app, I notice that it always says Handshake did not complete after 5 seconds, then it keeps on retrying.

I believe the only significant thing I’ve done on my new B1300 is changing stubby.yml to modify DNS over TLS from Cloudflare to NextDNS. I also use NextDNS as Private DNS on my Android phone. I don’t think this is the issue though, because I tried turning off encrypted DNS on both router and phone, but they still can’t connect to each other.

Is there anything else I could do to make this work? Thank you in advance.

I tried to help by viewing the youtube video but gave up because of the crass music which rendered the instructions impossible to follow - sorry!

I believe that video is from GL.iNet’s official YouTube channel haha

1 Like

You can mute the video and read the on screen text :stuck_out_tongue:

Put it back for testing purposes… you’ll find it might work better

:slight_smile:

Cloudflare works better if I want to use B1300 as WireGuard server? That’s quite a bummer if true. I really like NextDNS because I can use it as a DNS sinkhole. They also provide nice analytics dashboard and logs.

I’ll try Cloudflare again when I have time.

that shouldn’t have anything to do with WG server. i have no issues with using b1300 running a server.

Hi, did you only do the steps mentioned in the video and it just works? Or did you do something extra to make it work? Thanks.

yes. i did the same way the video says.

I’m seeing the same issue. I’m using a B1300 as my main router and I can access my public IP address externally and have port forwarding working for exposing services. I’ve tried the suggestions here but still not working. Did the OP get this working in the end?

EDIT: Got it working - forgot I had an active port forward rule for port 51820 from a previous Wiregaurd installation under Docker. Removed that and it fixed it.

1 Like