Trying to install minidlna on GL-AR750

Hi guys,

I’m trying to install minidlna on the GL-AR750, but i get this error:

root@GL-AR750:~# opkg install minidlna
Unknown package ‘minidlna’.
Collected errors:

  • opkg_install_cmd: Cannot install package minidlna.

But the package is listed here: 404 Page not found - GL.iNet

What am I doing wrong?

Thanks for your help!

I think if you do ‘opkg update’ first, then magic will happen and it will work.


Try also ‘opkg list | grep minidlna’

Hi Tom,

That’s not helping. I did that before I tried the install. Sorry, should’ve mentioned that.
Also in the web client, the package is not listed. I’m surprised about this… what can it be?

The minidlna doesn’t seem to be in the Packages.gz

You could try and wget all dependencies and install. Not sure if it will work

Might need gl-inet help to fix.

I tried this: root@luigi:/tmp# wget Downloading '' Connecting to

Writing to ‘minidlna_1.1.5-2_mips_24kc.ipk’

minidlna_1.1.5-2_mip 100% |*******************************| 104k 0:00:00 ETA

root@luigi:/tmp# opkg install minidlna_1.1.5-2_mips_24kc.ipk

Installing minidlna (1.1.5-2) to root…

.Collected errors:…

@tomsmith842, I assume that this is a bug that was introduced in LEDE opkg.

Hope to fix this later.

If it still does not show the files but you can access the collection it means the database has been populated with an empty file.
To rectify the issue delete the database file do:

rm /var/run/minidlna/files.db

Then restart MiniDLNA and it will rescan your Harddisk Drive for Media

/etc/init.d/minidlna restart

It’s working fine now after firmware update. This one can close.

It still isn’t working for me. I have the ar-300m and I get this error. I’m using fw 2.27

Update your firmware to the latest and it will work!

My AR-300 says the 2.27 is the latest…And that’s what I have. But still no dice.

Maybe you should upgrade to the latest testing firmware. You can find it here. Please untricked “keep settings” when upgrading.