Uboot fail 300a

I tried ddwrt…didn’t like it, tried three times to uboot back to V 2.22 and 2.24 with no luck. It gives me a 169.254 ip for awhile and once even gave back my 192.168.2.xx address…but twice I had to unplug and it gave me the .2 ip address back in ddwrt. Ugh. All I want is to get back to gli software…

What am I doing wrong and how can I flash the GLI software back to it@

There’s nothing wrong with DD and I’ve no idea what you are doing wrong.
presumably, you’ve read this:

No, I read the post that said to power off router, hold reset button, power on, and wait for three blinks. Then go to to the uboot gui to choose and flash firmware. It says it will reboot if it goes well…It never reboots, it just powers off the red LED (Wi-Fi) and stays like that.

And if you know a way to get DD on on my 300a to Wi-Fi WAN>ovpn>AP, you let me know. I could never get vlans to transmit, but I can on my 300n with GLI stock firmware.

Did you set your PC Lan adapter to something like 192.168.1.x before trying to load the new firmware?
And, can you post the link you are using as a guide?

Yes, that is how you get to the gui via Debrick via Uboot - GL.iNet Docs

Then what? You get the Uboot web interface and…?

what firmware are you using?

what happens when you try and upload it?

does the process complete?

See the first post. Nothing. Several. Change of DHCP. Probably not since DD remains on it.

@Jadurrance, the uboot should have nothing to do with ddwrt. I am not sure what is the problem.

Seems you have access uboot web UI and upload the firmware. At lease DDWRT will be erased.

Like I said, I am following that procedure and it isn’t erasing DD, nor is it installing the new firmware. How long should the process take?

It takes 3 minutes.

If I undertsand correctly, you can still have DD-Wrt on your router and can access it via the web interface?

If yes, you could try using WinSCP (WinSCP :: Official Site :: Free SFTP and FTP client for Windows) but BEFORE you do anything, please WAIT FOR ALZHAO TO COMMENT!

Load the firmware file >/tmp and write it manually (click the terminal icon) using this command:

mtd -r write /tmp/firmware.img image

(where firmware.img = the name of the firmware file - to avoid typos I recommend renaming the firmware file first eg. “myfile,img”)


If this fails you have another option using tftp2 via Uboot but try the above first (@ ALzhao, please comment on this too).


It is just hard to think of the reason.

Are you using windows? Version?

browser version?

is the mini router blue?

which bin file did you upload via uboot?






I’ll try again later tonight.

Tried 2.22 again in chrome. I went to the uboot screen and loaded the firmware, I saw the “loading x%” count to 100% in the bottom left of the screen, then the screen goes to the chrome “this site can’t be reached. Connection reset” page (presumably because the address changed). So I wait 5+ minutes and change it back to obtain IP automatically and I get The router never restarts, the red Wi-Fi LED never comes back, nothing else changes. I power cycle and it gives me back a .2 subnet and DD is still there like nothing had happened.

It looks like it’s just going to be easier to get DD working than it will be to get back to GLI firmware. I successfully got it receiving the Wi-Fi as a client and then repeater, but even after creating the vlan, it isn’t transmitting an ap.

I have the same situation with 6416. I can’t revert to GLI software from DD-WRT (tl-wr710v1) It is flashing via http, and via tftp, and next boot I have DD-WRT a new. If i try to flash from DD-WRT i received “can’t unlock mtd(x)”

I found that not easy to come back from DD-WRT. Have You a solution?

If you use uboot, try to erase the firmware complete first.

for example, for 6416, try: erase 0x9f020000 +0x700000

For AR150, try: erase 0x9f040000 +0x700000

Erase not working I see.