Uboot not responding in ar750s

so I was using the vanilla openwrt imagebuilder for for my ar750s worked fine but wanted to try 20.0.2rc2. flashed openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin nor (not nor/nand) from luci without keep settings and cant login from luci. figured I would just have to flash via uboot but uboot screen shows error with redirect to git hub for issues. git hub redirect did not show ar750s was supported. what next?

update: did reset button factory reset and was able to ssh into dropbear. changed password but still no luci login working.

I appear to have sysupgrade.bin with a micosd card inside .
this is the result from booting with it currently

root@OpenWrt:~# block info
/dev/mtdblock0: UUID=“14715xxxxx” VERSION=“1” TYPE=“ubi”
/dev/mtdblock6: UUID=“xxxxxxxxx-1a8d9629-07b5039a-40681daa” VERSION=“4.0” MOUNT=“/rom” TYPE=“squashfs”
/dev/mtdblock7: MOUNT=“/overlay” TYPE=“jffs2”
/dev/sda1: UUID=“xxxxxxxx-ffbf-4abb-a0ce-291250cd4d78” LABEL=“overlay” VERSION=“1.0” TYPE=“ext4”
/dev/sda2: UUID=“xxxxxxxx-1e3b-47ad-9aea-8c770d08180b” LABEL=“storage” VERSION=“1.0” TYPE=“ext4”
/dev/sda3: UUID=“xxxxxxxx-1694-4d3a-af5b-31081962fb73” VERSION=“1” TYPE=“swap”

here it is booted up without sdcard

root@OpenWrt:~# block info
/dev/mtdblock0: UUID=“1471xxxxxx” VERSION=“1” TYPE=“ubi”
/dev/mtdblock6: UUID=“00794cfc-1a8d9629-07b5039a-xxxxxxx” VERSION=“4.0” MOUNT=“/rom” TYPE=“squashfs”
/dev/mtdblock7: MOUNT=“/overlay” TYPE=“jffs2”

uboot working fine now card is removed.
flashed image openwrt-ar750s-3.201-0402.img from uboot and up again.

don’t recall ever having issues upgrading with system not mounted with extroot but /mnt/sda1/upper from old setup was there and caused issue?

so should I install
openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin nor (not the nor/nand file)
openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin nor/nand file

i remembered I had to flash vanilla first to get parttions aligned with vanilla openwrt so did a
uboot flash of gl-ar750s-3.0-1011_clean.img.

this casues same problem of having luci blank unset password login failure.

here is my block info
root@OpenWrt:~# block info
/dev/mtdblock0: UUID=“xxxxxx56xx” VERSION=“1” TYPE=“ubi”
/dev/mtdblock6: UUID=“00794cfc-1a8d9629-07b5039a-xxxxxxx” VERSION=“4.0” MOUNT=“/rom” TYPE=“squashfs”
/dev/mtdblock7: MOUNT=“/overlay” TYPE=“jffs2”

solution found problem… FIREFOX! I even was using the cache cleaner addon and still failed. switched to chromium and viola, I can log in to luci

but it’s not over.
it wont take the 20.2sysupgrade.bin from luci.

luci upgrade responds with
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

for both nor and nor/nand file for 20.2rc2
any help would be greatly appreciated

now its doing it from cleanglar750s.img


The page you were looking for doesn’t exist!

You can find more information about this project on GitHub

good grief
aiuta! (help in italian) :wink:

wont take any upgrade now

root@OpenWrt:/sbin# ./block info
/dev/mtdblock5: UUID=“147157xxxx” VERSION=“1” TYPE=“ubi”
/dev/ubiblock0_0: UUID=“axxxxx76-44e69463-38cf809c-b6xxxxx” VERSION=“4.0” MOUNT=“/rom” TYPE=“squashfs”
/dev/ubi0_1: UUID=“6xxxxxx26c1-9241-461e-9974-474cxxxxx” VERSION=“w4r0” MOUNT=“/overlay” TYPE=“ubifs”

root@OpenWrt:~# ls /dev/mtd*
/dev/mtd0 /dev/mtd1ro /dev/mtd3 /dev/mtd4ro /dev/mtdblock0 /dev/mtdblock3
/dev/mtd0ro /dev/mtd2 /dev/mtd3ro /dev/mtd5 /dev/mtdblock1 /dev/mtdblock4
/dev/mtd1 /dev/mtd2ro /dev/mtd4 /dev/mtd5ro /dev/mtdblock2 /dev/mtdblock5

is recovery as easy as a missing unformated partition?

decided to try uboot again for the fourth time. cleared browser cache before connecting failed. cleared browser cache while still connected. worked. flashed the 20.2rc2 nor file successfully

Typical problem of browser cache.

with the speed of todays networks and large ram on computers it should just be disabled lemme know if this should be enough for firefox
browser.cache.disk.enable false