Uboot on AX1800 does not work!

Installed ExpressVPN Aircove firmware on AX1800. Everything worked perfectly well. After few months, I decided to go back to Flint’s original firmware. Followed the procedure (resetting, static ip etc) and I could and can see flashing LED few times and then solid white/grey. But I can not access no matter what. Have I completely bricked the router? With no reset, I get a solid blue LED but completely dead otherwise. Can I uboot through serial? Any help is appreciated.

Did you make sure only 1 cable is connected to LAN or WAN port?

I do not work for and I do not have formal association with GL.iNet.

After restart your device in uboot mode and setting your computer’s network card to, have you tried pinging your AX1800 with

Us a private browser window and flush DNS.

I saw this happen to me with chrome, the uboot http server code is very fragile, and chrome may do multiple requests and cause the response to hang, try with firefox. set static ip with subnet mask and plug in only 1 single cable into lan port.

Thanks for all the replies. I tried all the above but still not responding I am afraid:

  1. I had one cable connected to LAN port. Also tried WAN port. still no response.
  2. I tried → no response
  3. I had already changed the DHCP to static, with No ping response
  4. Private browser tab did not help either. I tried Edge instead of Chrome, that didn’t help either.

Any other suggestions?

Let’s try this

  1. Make sure the router is turned on.
  2. Hold the reset pin for about ten seconds.
  3. The LED will flash four times.
  4. Check if the issue is resolved.

Repeat this process three more times.

I tried that in two scenarios, and with neither I get LED flashing 4 times.

Scenario 1 → Turned the router on as is and I get solid blue LED.
Scenario 2-> Pressed the reset button, then power on with one ethernet cable connected to PC. LED flashes blue and white few times and then turns solid white. Then released the reset button. Then hold the reset button for 10s or more but no LED flashing.

Does solid white LED by definition suggests that uboot is loading but it’s just that I am not able to access it?

How about the ExpressVPN router page? Can access or not?

I tried that too, nothing! I also tried to ping sweep the whole ip range from all the way to, no ping response.
Can the USB be used to do anything?

I’m not sure about the new routers, but the old ones had the ability to connect via the UART connector and use a tftp server for UBoot. I would like to contact GL-inet support for details.

I’ll keep that as my last resort :slight_smile:
Any crazy suggestions?

After you set your pc ip to you access the uboot at not
And disconnect wifi and any other lans with same ip range.

That’s what I did. I also tried as someone suggested that previously. AirCove uses or as gateway ip.

OK believe it or not I have found the problem! I knew that AirCove firmware used as the default gateway but I always thought by resetting, everything resets to I changed the static ip to and then changed default to and ta-da I have the uboot page! Thanks for the all the help. It really helped to narrow down the problem.


You mean set the static ip to instead of, then access for uboot page instead of

yes. ExpressVPN’s AirCove is to blame

They are trying to config the setting for uboot since got Aircove

That is wrong Uboot procedure is

  1. unplug from wall power
  2. have only one ethernet cable plugged in
  3. change computer to static ip of 192.168.1.x( anything up to 254 and not 1)
  4. holding the power button or reset button plug the power back into wall and keep holding power reset button till light goes solid.(if you let go it will not work)
  5. enter into a private widow browser