Uboot update failed on the opal

I have the OPAL router. It’s not had a UBoot update since I purchased it almost 2 years ago. I got the Uboot and firmware from GL.iNet download center

on uboot the update fails when trying to update it at http://192.168.1.1/uboot.html
The firmware doesn’t update either saying the size isn’t correct when just going to straight http://192.168.1.1/

I have downloaded both files multiple times now, getting the same error each time. Trying on firefox and edge browsers.

You’re pulling down the openwrt-sft1200-4.3.7-1222-1703236005.img & not the .tar, yeah? I’d check its sha256 checksum. It’s not unheard of that bad downloads happen.

Related: I find it’s always best to use Incognito/Private Mode when dealing w/ anything related to GL device config. Browser caching is a bit of a b!7ch.

Can you give me the uboot upgrade download link?

It’s this one:
https://fw.gl-inet.com/firmware/sft1200/release4/openwrt-sft1200-4.3.7-1222-1703236005.img

It’s on the same page.

1 Like

that’s the firmware update if I’m not mistaken

Blockquote

. I am referring to the uboot update…

1 Like

Damn, you are right - I did not understand the question :laughing:
Uboot files are here: https://github.com/gl-inet/uboot-for-qca95xx/tree/master/bin
But none of them are suitable for your device, not sure if there are any.

Wait… are you looking to update the U-boot version itself (eg: U-boot 2014.10) or update the GL firmware using U-boot (eg: openwrt-sft1200-4.3.7-1222-1703236005.img)?

I was trying to update the uboot version cause it looks like it’s an old version. it doesn’t look like the ones on the gl-inet support site walking through the process.

Using U-boot is a matter of ‘last resort.’ The Opal is an older model so I wouldn’t be surprised if U-boot isn’t quite ‘the latest & greatest.’ It’s not something you’d ideally need to touch. Are you not able to flash the .img using the current version of U-boot on the Opal?

I tried to update this via uboot… it shows
UPDATE IN PROGRESS
Your file was successfully uploaded! Update is in progress and you should wait for automatic reset of the device.
Update time depends on image size and may take up to a few minutes. You can close this page.

I’ve waited 10+ minutes but it doesn’t ever reboot the device. is it supposed to auto reboot after it’s updated?

I only was going to update the uboot cause I thought it was needed.

It should, but it’s OK if you just unplug it by yourself after a couple of minutes.
Make sure to revert the IP settings of the device you use for configuration.

1 Like

When the flashing is successful the Opal’s IP will revert to the GL stock of 192.168.8.1… but your connected computer will still have 192.168.1.1 as will the web browser trying to connect to that now out of date IP address.

Be sure to remove 192.168.1.x fr your computer’s IP settings.