UBoot Update Failure [RESOLVED]

Hello All,

I have a GL-AR300M16-ext, I updated the firmware last night and I think I’ve kept the ‘maintain settings’ option which seems to of bricked it.

I’ve followed the uboot instructions to upload the firmware and unbrick. However, it doesn’t work. I am able to boot into the safe mode, login to with a specific device IP, I then see the below screen:

I upload and apply the file and see the page that states the upload was successful etc.

The second green light turns off for a minute, red flight flashes, both middle green and red lights flash, then turns back on, indicating an update/reboot.

But nothing has changed. No wifi light. Cannot connect to admin panel normally (even after changing IP).

I’ve tried the switch option on the page, still no luck.

I’ve tried the latest Stable build and the latest Beta build.

I have a Mac so limited with uboot options. Can anyone help?

Thanks in advance for any and all help/comments.

After trying the same thing over and over, it’s finally working! Resolved.

Random, but relieved it’s working.

1 Like