Unable to Access Router's Web Interface through Switch: Need Help!

Hello everyone,

I’ve set up a router (model STF-1200 Opal) to act as the gateway for my network as well as a DHCP server. Its range is set to For internet connectivity, it connects to the WAN through a modem provided by my ISP, authenticating via PPPOE, and it’s connected through its WAN port. The internet works flawlessly.

For my local network, I have connected an 8-port unmanaged TPLink switch to the router’s LAN port. This switch caters to TVs, computers, and servers through wired connections. All devices on the local network work perfectly; they have internet access and can communicate with one another locally.

However, I’ve encountered a puzzling issue: when I attempt to access the router’s web configuration interface using its IP ( from my computer, which is connected to the switch, the web interface simply doesn’t load. The browser doesn’t display an error message; it just endlessly loads. Interestingly, when I connect my computer directly to the second available LAN port on the Opal router, I can access the router’s admin web interface without a hitch.

Considering the switch is unmanaged and everything else on the local network is accessible, I’m at a loss as to what might be causing this. Any insights or suggestions would be greatly appreciated. Thank you!

That .1 should be a .0; I assume you mistyped or could it be the issue?

Sorry about that, I’ve mistyped it. Thanks for noticing.

1 Like

And your wired clients get their config via DHCP from the Opal router? Or did you config them manually?

I have about 30 fixed IPs addressees from local devices, all DHCP is handled by the OPAL, one of them is my computer in this case.

I’ve just tried another computer, connected to the switch, without fixed IP and the same problem: works directly to the OPAL, doesn’t with the switch…

I was suspecting a client with a broken subnet mask or default gateway setting, but that’s not very plausible if DHCP handles all of that.

By fixed IP you mean an actual fixed IP, not a static DHCP lease, right?

Because in that case my suspect comes back in play.

Yes, sorry again. It is a static DHCP lease, not a request for a specific IP from the device to the DHCP.

I’m only able to access it from the GoodCloud service ATM…

Well, in the default configuration DHCP gets IPs from .100 onwards.

You can manually assign .2 to .99 (actual manual config!)

But this sounds like a iso/osi layer 2 issue. Let’s hear the others.

1 Like

Hi guys. I’m not sure what happened, I’ve been trying to fix it for days, I’ve tried everything. After removing and reinstalling the network adapter, it just worked. Thanks, everyone.