Unable to change DNS

Anyone can help me? i’m on AR-750


When you turn on “DNS over TLS from Cloudflare”, you cannot change DNS manually. It is exclusive.

yes i know, but i can’t turn off cloudflare toggle
all grey toggle are untouchable

ps this happens after i joke with adguard home and dhcp file, but now i replace the original by umounting my extroot partition

There must be something wrong. As "Cloudflare "and “Manual DNS” cannot be turnned on at the same time. So it is impossible that they both grayed out.

If you cannot maybe you need to reset your firmware. Now sure why.

1 Like

looks like he might have lost connectivity to the web page and at some point it encountered a web error. .
what firmware vesion for ar750?

is it still stuck in that state after rebooting?

(sometimes even the smallest inconspicuous error leads bach to large unknown one)

i’m on 3.104
no problem for weeks until i installed adguard and played bad with dnsmasq and DNS port
now restored my backup and solved

Maybe you messed up the settngs with adguard. There a a lot of issues to solve related to DNS.

Is there any time frame when this will be fixed?
I have upgraded to ver 3.103 on a GL-AR750 after resetting firmware and reloading firmware. I’ve read release notes for ver. 3.105 test ver and it’s still not fixed.
I’ve tried settings DNS over TLS set to Cloudfare and come back it resets to NextDNS.
Tried manual DNS server settings, set to and and the whole time its pinging and I verified this with wireshark. I checked with a lan tap between computer and router then between router and network, it is coming from the router. Is there a work around to stop the pinging of google?

Seems you are posting in a wrong thread. Your issue is realted to mwan3. You can try to stop mwan3 and you will lost multi-wan functions.

Hi @alzhao i think this can be replicated.

  1. turn on cloudflare dns on GL GUI
  2. go into LuCi and change dns.

result is that back in GUI will become as per first post, cloudflare and manual will both be switched on.
can fix it via SSH by manually turning it off in glconfig.

1 Like

I see. Let me check how to fix that.