Unable to configure MT300N-V2 with usb wifi adapter + repeater mode

Hello community, I have a MT300N-v2. I’d like to add a USB wifi dongle to the router for the repeater feature. I’m running openwrt-mt300n-v2-3.026-0729 firmware.

First question is will this increase my throughput speed when connected to the repeater?

I’ve tried to configure 2 different dongles (Asus ralink 28xx based and a generic mediatek mt7601 based)
The router’s logs appear to see the devices, but when I try to add an interface I dont see a new one, or I dont know what it’s called to add a custom interface. Really, I dont know what I’m doing here.

The one thing I do notice, is that after I add the software package, scanning networks no longer displays any results (or the box that the networks would be listed in) but the connection still works if I previously associated a wireless network to the repeater.

Does anyone have any advice or a step by step guide to help me out?

Can you share your configuration?

Here’s my network config:
cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:a346:5cdb::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-MT300N-V2-1e2'
        option ipaddr '192.168.8.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option hostname 'GL-MT300N-V2-1e2'
        option metric '10'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'e4:95:6e:49:61:e2'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Also here’s whats happening with the repeater menu.
Before adding dongle driver:

After:

There is no configuration for dong.
Our interface does not fit this dong, so it cannot be operated in the interface. You need to configure this dong first and then operate in luci

How do I configure the dongle? I’ve installed the drivers but I don’t see a way to configure.

Can you post the content of /etc/config/wireless?

Pls mark your wifi password.

I am desperately trying to accomplish the same concept. Did you ever find a solution ? tks.

1 Like