Unable to connect to internet using beryl


I have a beryl router and I connect it through WAN.
The light turns white.
I connect to my routers wifi / cable (I tried both).
I test out going to google.com
No internet.

On Windows when I hover over my wifi icon it says “VirtualBox Host-Only Network”

Can you post a screenshot of the main Admin Panel - Internet page that displays the router and all its connections?

I do not work for and I do not have formal association with GL.iNet

I would like to answer my own question.
I was connecting to a “Shaw) Fibre+ Gateway 2.0”

I called their tech support and they directed me to a support page on how to connect a third party router to their modem.

I was instructed to connect to the modem via browser.
Set router into Bridge Mode.
The wifi is now disabled and my third party router will act as the wifi broadcasting device.

I unplug the modem and the beryl router.
I connect both unplugged devices by ethernet cord via WAN.
I plug in only the modem.
Once the modem shows a status light indicating its connected to the internet.
I then plug in the router to power.

I was still having issues after these steps.
I disabled manual DNS settings and then my beryl router works.

I tried to be as detailed as possible so if anyone in the future has these issues they can search the forums and finds these steps.

1 Like

You mean the manual DNS setup breaks the Internet? What manual DNS did you set up?

1 Like

I had previously set manual DNS server 1 and 2 to the same Sepctrum / Charter Communications DNS.

So these settings were active on my first attempt to setup with this Shaw modem.

I disabled manual DNS then the internet suddenly started working.

I re-enabled and input the exact same settings. It now works and says my DNS is Sepctrum / Charter Communications. I assume this has to do with the first initial connect? I am unsure. However this fixed it.

1 Like