Unable to connect to SIM


I have a GL-MIFI-E router and I’m trying to connect with LTE without succsess.

I have installed the newest LEDE firmware and luci-proto-qmi package. The modem is setup with all pamameters like access point, user/pw and auth mode.

If I insert a SIM card the modem does not respond anymore on uqmi commands.

I have tried multiple SIM cards but anytime the same issue. How I get this LTE setup running?

Thanks for help

Best Regards

Have your tried the stock firmware. It has everything installed. Why you install extra packages.

Two things:

  1. SIM card doesn’t support plug and play. You need to power off and power on again. Or just reset the modem from the UI.
  2. The corner cut of sim should face outside.

Hi ,
yes I have tried stock firmware as well and don’t got it running.

Therefore I was trying to fix this and have upgrade it to newest firware what was offered here in the download store. This hould not be a problem or? the luci-proto-qmi package was mentoned on the openWRT website. It is offering additional advanced modem settings in the GUI.

Yes I hvae rebooted the device multiple times it doesnt help. Yes I have the SIM pluged in as shown on the sticker. I’ve also tried all other directions without succsess.

The modem yust seems like to be busy, does not responding. I need to cancel any uqmi command with getting back “failed to connect to service”.
If I take the SIM out I get responses.

BR Reik

Make sure you have the correct APN settings for your provider.

can you try uing ttyUSB mode, no qmi. The uqmi scripts does have some bugs and we tried to fix several times. Still stuck sometimes.

yes the ttyUSB mode is working with LEDE

many thanks